Přeskočit navigaci | Přeskočit na novinky
     

Jste zde: Úvodní stránka » excel » zaklady » operatory-excel
Logo pokročilý

Operátory v Excel


Videokurzy Excel

Ve spolupráci se SEDUO jsem vytvořil několik videokurzů:

aneb znaménka (znaky), které jsou používaná v Microsoft Excelu jejich využití, jaké mají priority, ...

Doplněno: 23.5.2014

Úvodem

V tomto článku jsou představeny různé typy operátoru (znamének) , které jsou používany v Microsoft Excelu. Jak se dají tyto operátory dají použít.

Operátory určují typ výpočtu, který chcete s prvky vzorce provést. V aplikaci Microsoft Excel jsou zahrnuty čtyři typy (kategorie):

  • matematické (aritmetické)
  • relační
  • textové
  • odkazovací

Kapitoly

Pro přehlednost je článek rozdělen na kapitoly:

Vzorec

= Vzorec v Excel vždy začíná znaménkem rovná se (=). Toto znaménko označuje, že následující znaky tvoří vzorec, který Excel vypočte. Po zadání =1+2 se v buňce objeví 3

=1+2

Zobrazit vzorec jako text

Excel automaticky po zadání znaku rovná se začne následující text brát jako vzorec (chce počítat). Obejdete použítím apostrofu:

' apostrof - co je za apostrofem se bere jako text (tedy i znaménko rovná se), takže '=1+2 neprovede výpočet ale zůstane zobrazeno vše co je za apostrofem tj. =1+2

'=1+2

Poznámka: Pokud chcete zobrazit apostrof musíte jej zadát 2x (ten první se totiž nezobrazí).

Měna ve vzorci

Jak na vzorce, pokud chcete mít číslo i s měnou (veličinou)?

=10*"150 Kč"

Prostě číslo s měnou uvádět v uvozovkách. Pozor funguje jen na měnové jednotky.

'funguje =10*"150 €" 'nefunguje =10*"150 Euro"

Aritmetické operátory

Jak již název napovídá jsou určeny k provádění matematických výpočtů (sčítání, odčítání, násobení...).

Operátor Popis Význam Příklad
+ znaménko plus Sčítání 1+1
znaménko minus Odčítání 5–2
znaménko minus Záporné číslo –1
* hvězdička Násobení 2*2
/ lomítko Dělení 10/2
% procento Procenta 10%
^ „stříška“ Umocnění 2^2

Příklad

=1+2

Relační operátory

Využití pro porovnávání dvou hodnoty, kdy výsledkem je logická hodnota PRAVDA nebo NEPRAVDA.

Operátor Popis Význam Příklad
= znaménko rovná se Rovná se A1=B1
> znaménko větší než Větší než A1>B1
< znaménko menší než Menší než A1<B1
>= znaménko větší než nebo rovno Větší než nebo rovno A1>=B1
<= znaménko menší než nebo rovno) Menší než nebo rovno A1<=B1
<> znaménko nerovná se Nerovná se A1<>B1

Příklad

=A1=B1

Textové operátory

Například pro spojení (zřetězení) jednoho nebo více textových řetězců. Bude vytvořen jeden dlouhý řetězec.

Operátor Význam Příklad
& Spojuje jednotlivéhodnoty do souvislé textové hodnoty. „Auto“&„mobil“

Příklad

="Auto"&"mobil"

Odkazovací operátory

Pro kombinování oblasti buněk, například ve výpočtech.

Operátor Popis Význam Příklad
: dvojtečka operátor oblasti Jeden odkaz na všechny buňky mezi dvěma odkazy včetně těchto odkazů (B2:C5)
; středník operátor sjednocení Kombinuje více odkazů do jednoho odkazu (sjednocuje) (B2:C4;C7)
mezera operátor průniku Vytváří jeden odkaz na buňky společné dvěma odkazům (tj. průnik), viz ukázka (B7:D7 C6:C8)

Dvojtečka - operátor oblasti

operátor oblasti - dvojtečka - Excel

Příklad

=SUMA(B2:C5)

Středník - operátor sjednocení

operátor sjednocení - středník - Excel

Příklad

SUMA(B2:C4;C7)

Mezera - operátor průniku

Pro ty kteří mají raději grafické vysvětlení jak funguje operátor mezera.

operátor průniku - mezera - Excel

Příklad

=SUMA(B7:D7 C6:C8)

Nadřazenost (priorita) operátorů

Zkombinování několika operátorů do jednoho vzorce, se budou operace prováděny v pořadí podle níže uvedených priorit. Pokud je ve vzorci několik stejně nadřazených operatorů (násobení a dělení), jsou operátory vyhodnoceny zleva doprava. Chceteli něco upřednostnit musíte použít závorky =(2+2)*2.

Priorita Operátor Popis Poznámka
1 : dvojtečka  
2   jedna mezera  
3 ; středník  
4 zápor (unární operátor) např –1
5 % procenta 20%
6 ^ umocnění  
7 * / násobení a dělení  
8 + – sčítání a odčítání  
9 & spojení (zřetězení) řetězcu  
10 = < > <= >= <> srovnání  

Poznámky - unární operátor mínus

Definice: unární operátor je operátor, který pracuje jen s jedním operandem, tj. ve výrazu 1 + (-2) je plus binárním operátorem a mínus v závorce je unární operátor pro dvojku.

Proto doporučuji používat čísla s operátorem v závorkách. Ne vždy Excel pochopí správně (například dvě "mínus" za sebou při umocňování, ...) co je znaménko a co unární operátor, protože unární operátor má prioritu.

Unární operátor - Excel

Závěrem

Napadá vás nějaké doplnění k tomuto tématu? Můžete doplnit do komentářů.

Článek byl aktualizován: 19.09.2020 11:07

Odměna

Ušetřil vám tento web čas, peníze? Pomohl vyřešit problém? Jste ochotni poskytnout symbolickou odměnu na další rozvoj? Vybrte si formu odměny, která vám vyhovuje.


Pavel Lasák - autor webu

Pavel Lasák

Microsoft Office (Word, Excel, Google tabulky, PowerPoint) se věnuji od roku 2000 (od 2004 na této doméně) - V roce 2017 jsem od Microsoft získal prestižní ocenění MVP (zatím jsem jediný z ČR v kategorií Excel). Své vědomosti a zkušenosti dávám k dispozici i on-line ve videích pro SEDUO. Ve firmách školím a konzultuji, učím na MUNI. Tento web již tvořím přes 15 let. Zdarma je zde přes 1.000 návodu, tipů a triků, včetně přes 250 různých šablon, sešitů.

   Pavel Lasák LinkedIn Profil    Pavel Lasák Google+ Profil    Pavel Lasák facebook Profil    Pavel Lasák twitter Profil


Komentáře

" ; // echo "kompletni_cesta :" ; // echo $adresar_pro_vkladani ; // echo "
" ; // echo " Tady bude možnost přidání komentáře" ; // echo "
" ; // echo "
" ; $kompletni_cesta = "komentare"; $adresar_pro_vkladani = $kompletni_cesta; ?> \n"; reset($polozky); while (list($key, $val) = each($polozky)) { if ($val != "." && $val != "..") { if (!is_dir($val)) { // echo "$val
\n"; $fp = FOpen ($adresar_pro_vkladani."/".$val, "r"); //otevře soubor book.dat pro čtení $data = FRead ($fp, FileSize($adresar_pro_vkladani."/".$val)); //přečte data ze souboru a uloží do proměnné "data" - kvůli tomu aby se zobrazoval poslední příspěvek nahoře FClose($fp); echo "$data"; } } } ?>




Excel


Sdílejte

Pomohl Vám návod?
Sdílejte na Facebooku, G+
LinkedIn...

Nové články


Reklama


TOPlist Licence Creative Commons webarchiv rss XML

Stránky o MS Office (Excel) produktu společnosti Microsoft. Neslouží jako technická podpora.
| Email na autora: pavel.lasak@gmail.com | Copyright © : Pavel Lasák 2004 - 2020 |