Přeskočit navigaci | Přeskočit na novinky

Nový videokurz na Seduo: Excel pro začátečníky

     

Jste zde: Úvodní stránka » excel » data » unikatni-filtrovana-data-pocet-excel

Unikátní filtrovaná data počet - Excel


Jak v tabulce, která je filtrovaná zjistit počet unikátních (jedinečných) dat?

Aktualizováno: 2.8.2014

Excel - unikatní hodnoty

Cílem článku

Z tabulky, nad kterou je/bude proveden filtr, potřebujete spočítat zobrazená jedinečná data (tj. hodnoty počítat pouze ze zobrazených/filtrovaných hodnot? Viz ukázka:

Poznámka: Tabulka již je vyfiltrována, takže všech 5 unikátních hodnot z celé tabulky nelze vidět (tj. jsou "schovány" hodnoty DDD, EEE)

Kapitoly:

Pro přehlednost je článek rozdělen na jednotlivé kapitoly:


Vstupní data

Pro příklad si připravte si vstupní tabulku (data):

Období Hodnota id
jaro AAA 1
leto AAA 2
podzim AAA 3
zima AAA 4
jaro BBB 5
leto BBB 6
podzim BBB 7
zima BBB 8
jaro CCC 9
leto CCC 10
podzim DDD 11
zima EEE 12

Poznámka: Tabulka je jednoduchá záměrně, na první pohled zjistíte, zda vzorce počítají správně.

Předpokládané znalosti

V dalším předpokládám tyto základní znalosti těchto funkcí:

Postup řešení - Jak na to?

Využijeme funkce SUBTOTAL, KDYŽ a SOUČIN.SKALÁRNÍ s COUNTIF:

SUBTOTAL - Zjišťujeme, zda je hodnota ve filtru. Pokud je viditelná výsledek 1

=1*SUBTOTAL(3;$C5)

Pokud je viditelná tak se v tabulce zobrazí odpovídající hodnota.

=KDYŽ(B22;$C5;"")

Spočteme počet filtrovaných hodnot například:

= SOUČIN.SKALÁRNÍ(KDYŽ(C22:C33<>"";(1/COUNTIF(C22:C33;C22:C33));0))

A je hotovo ...

Doplnění - rozšíření

Pokud vám nejde o unikátní data, ale chcete provést součet sloupce, který splňuje určité podmínky dle jiných sloupců (závislá data) doporučuji článek: Závislá filtrovaná data suma - Excel - to vše bez využití programování (VBA kódu). Pouze funkce, které jsou v Excelu k dispozici.

Hotovo

MS Excel 2010 - unikatní hodnoty

Ke stažení

Soubor Počet jedinečných dat ve vyfiltrované tabulce soubor ve formátu *.xlsx pro Excel 2010 (2007) ke stažení zdarma.

Související články

Závěr

Jak počítáte jedinečná (unikátní) data vy? Máte nějaký lepší a rychlejší způsob? Můžete se zmínit v komentářích.

Článek byl aktualizován: 01.11.2014 09:22

Odměna

Ušetřil vám tento web čas, peníze? Pomohl vyřešit problém? Jste ochotni poskytnout symbolickou odměnu na další rozvoj? Vybrte si formu odměny, která vám vyhovuje.


Pavel Lasák

Pavel Lasák - autor webu

Microsoft Office (Word, Excel, PowerPoint) se věnuji od roku 2006. Své vědomosti a zkušenosti dávám k dispozici na různých školeních a konzultacích, ale také na tomto webu. K dispozici na tomto webu je mnoho návodu, tipů a triků včetně desítek různých šablon.

   Pavel Lasák LinkedIn Profil    Pavel Lasák Google+ Profil    Pavel Lasák facebook Profil    Pavel Lasák twitter Profil

Doporučte tento článek přátelům

Pokud vám článek pomohl, případně si myslíte, že může pomoci i někomu dalšímu, budu rád když jej sdílením doporučíte přátelům - děkuji:



Komentáře


Kolemjdouci

Přidáno: 30.07.13 19:33

=SUMA(KDYŽ(SUBTOTAL(3;POSUN(A16;ŘÁDEK(A16:A160)-16;0));(1/SOUČIN.MATIC(--(A16:A160=TRANSPOZICE(KDYŽ(SUBTOTAL(3;POSUN(A16;ŘÁDEK(A16:A160)-16;0));A16:A160;"")));SIGN(ŘÁDEK(A16:A160))));0))

Pavel Lasák

Přidáno: 31.07.13 07:08

To Kolemjdouci: Děkuji za velice zajímavý vzorec (není využito odpovědi z pc-help.cz)?
Pro tabulku v tomto článku ale vzorec nebude fungovat :(. Musel by se upravit do podoby: =SUMA(KDYŽ(SUBTOTAL(3;POSUN(C5;ŘÁDEK(C5:C16)-5;0));(1/SOUČIN.MATIC(--(C5:C16=TRANSPOZICE(KDYŽ(SUBTOTAL(3;POSUN(C5;ŘÁDEK(C5:C16)-5;0));C5:C16;"")));SIGN(ŘÁDEK(C5:C16))));0)) Opět se musí zadat jako maticový (Ctrl+Shift+Enter).

Myslím si, že je na pochopení pro začátečníka, poměrně složitý (pokud chce tento vzorec aplikovat na vlastní tabulku).







Sdílejte

Pomohl Vám návod?
Sdílejte na Facebooku, G+
LinkedIn...

Nové články

09.02.2017:
Jak na logaritmy LN, LOG, LOGZ

14.02.2017:
TEXTJOIN spojuje texty a přidá oddělovač

19.03.2017:
AVERAGEIFS, AVERAGEIF


Newsletter

Přihlaste se odběru novinek a získejte:
Ebook zdarma -
10 kroků ke zvládnutí (Word, Excel, PowerPoint)
Šipka Kniha 3D Více o ebooku ...

TOPlist Licence Creative Commons webarchiv rss XML

Stránky o MS Office (Excel) produktu společnosti Microsoft. Neslouží jako technická podpora.
| Email na autora: pavel.lasak@gmail.com | Copyright © : Pavel Lasák 2004 - 2017 | 7044

Tento web zatím neprošel jazykovou korekturou. Beta verze redakčního systému.