Přeskočit navigaci | Přeskočit na novinky

Videokurzy na Seduo: Excel pro začátečníky (přes 13.000 studujících) nebo kompletní kurz Excel (6 hodin - 160 videí).

     

Jste zde: Úvodní stránka » excel » data » Razeni-Excel-bug-problem
Microsoft Excel logo

Řazení Excel - bug - problém


Pozor na řazení v Excel - pro výpočty může řadit špatně! Rozhodí odkaz na název listu!

Úvodem

Máte tabulku s výpočty a řadíte? Excel vám může rozhodit data.

Mějte jednoduchou tabulku. Kdy sčítáte čísla v řádku. Podobně neumí ani jednoduchý výpočet, kde například název pozice dosazujete přes funkci SVYHLEDAT pomocí funkce SVYHLEDAT.

Tabulka 1

Tabulka 1 - ŘAZENÍ

Tabulka 2

Tabulka 2 - ŘAZENÍ

Použijeme vzorce

Pro klasický výpočet - tabulka 1

=B6+C6 =List2!B6+List2!C6

Pro využití SVYHLEDAT - tabulka 2

=SVYHLEDAT(List1!$B6;$F$6:$G$8;2;0) =SVYHLEDAT($B6;$F$6:$G$12;2;0)

Prostě se jen odkazujeme i na název listu.



Co se stane při řazení

Pro klasický výpočet - tabulka 1

=List2!B8+List2!C6 >> odkazuje na jiný řádek

Pro využití SVYHLEDAT - tabulka 2

=SVYHLEDAT(List1!$B8;$F$6:$G$8;2;0) >> odkazuje na jiný řádek

A problém je na světě!


Tabulka 1 - ukázka

Tabulka 1 - ŘAZENÍ

Tabulka 2 - ukázka

Tabulka 2 - ŘAZENÍ

Související články

Třeba se vám bude hodit další související články:


Závěrem

Znáte tento bug? Jen pro doplnění nezvládají ani Google tabulky ;)


Článek byl aktualizován: 07.04.2017 19:52

Odměna

Ušetřil vám tento web čas, peníze? Pomohl vyřešit problém? Jste ochotni poskytnout symbolickou odměnu na další rozvoj? Vybrte si formu odměny, která vám vyhovuje.


Pavel Lasák

Pavel Lasák - autor webu

Microsoft Office (Word, Excel, PowerPoint) se věnuji od roku 2006. Své vědomosti a zkušenosti dávám k dispozici na různých školeních a konzultacích, ale také na tomto webu. K dispozici na tomto webu je mnoho návodu, tipů a triků včetně desítek různých šablon.

   Pavel Lasák LinkedIn Profil    Pavel Lasák Google+ Profil    Pavel Lasák facebook Profil    Pavel Lasák twitter Profil

Doporučte tento článek přátelům

Pokud vám článek pomohl, případně si myslíte, že může pomoci i někomu dalšímu, budu rád když jej sdílením doporučíte přátelům - děkuji:



Komentáře zatím nejsou

Můžete být prvními co zanechají smysluplný komentář.







Sdílejte

Pomohl Vám návod?
Sdílejte na Facebooku, G+
LinkedIn...

Nové články

25.03.2017:
ROUNDUP, ROUNDDOWN - zaokrouhlování

07.04.2017:
Řazení Excel - bug - problém

09.04.2017:
Podmínkové funkce Excel - bug - problém


Newsletter

Přihlaste se odběru novinek a získejte:
Ebook zdarma -
10 kroků ke zvládnutí (Word, Excel, PowerPoint)
Šipka Kniha 3D Více o ebooku ...

TOPlist Licence Creative Commons webarchiv rss XML

Stránky o MS Office (Excel) produktu společnosti Microsoft. Neslouží jako technická podpora.
| Email na autora: pavel.lasak@gmail.com | Copyright © : Pavel Lasák 2004 - 2017 | 240

Tento web zatím neprošel jazykovou korekturou. Beta verze redakčního systému.