Přeskočit navigaci | Přeskočit na novinky
     

Jste zde: Úvodní stránka » excel » data » zavisla-filtrovana-data-suma-excel

Zavislá filtrovaná data suma - Excel

Videokurzy Excel

Ve spolupráci se SEDUO jsem vytvořil několik videokurzů:

Jak z tabulky, vypočítat sumu zavislých dat, navíc těch, která jsou součásti filtru?

Cílem

Je potřeba v tabulce s daty nad kterou je proveden filtr spočítat sumu, která odpovídá závilým (hierarchicky) hodnotám. Například u organizační struktury.

Takže máte tabulku s pracovníky, kdy někteří pracovníci jsou vrchí bosové, někteří malí šéfové a ten zbytek Ti co to odpracují ;). Nejlépe je to pochopitelné na ukázce:

MS Excel 2010 - hierarchická data

Spočtou se náklady pracovníka SSS a jeho podřízených. Navíc pouze těch, kteří jsou zobrazení. Například se vyfiltrují všichni středoškoláci, atd.

Poznámka: Námět na tuto úlohu byl položen na webu excelentnítriky, ale komentáře nepodporují vkládání obrázku tak jsem vytvořil tento článek.

Jak na to?

Využijeme fukce SUBTOTAL, SOUČIN.SKALÁRNÍ, POSUN, ŘÁDEK, MIN:

Pro první sloupec "Šéfové"

=SOUČIN.SKALÁRNÍ(SUBTOTAL(3;POSUN($A$11:$A$25;ŘÁDEK($A$11:$A$25)-MIN(ŘÁDEK($A$11:$A$25));;1));($A$11:$A$25=A5)*($D$11:$D$25))

Pro všechny tři sloupce:

=SOUČIN.SKALÁRNÍ(SUBTOTAL(3;POSUN($A$11:$A$25;ŘÁDEK($A$11:$A$25)-MIN(ŘÁDEK($A$11:$A$25));;1));($A$11:$A$25=A5)*($D$11:$D$25))+ SOUČIN.SKALÁRNÍ(SUBTOTAL(3;POSUN($B$11:$B$25;ŘÁDEK($B$11:$B$25)-MIN(ŘÁDEK($B$11:$B$25));;1));($B$11:$B$25=A5)*($D$11:$D$25))+ SOUČIN.SKALÁRNÍ(SUBTOTAL(3;POSUN($C$11:$C$25;ŘÁDEK($C$11:$C$25)-MIN(ŘÁDEK($C$11:$C$25));;1));($C$11:$C$25=A5)*($D$11:$D$25))

A je hotovo ... Určitě jde vypočíst i jinak. MAte-li elegantnější řešení můžete uvést do komentářů.

Ke stažení

Soubor Součet hodnot dle požadavku ve vyfiltrované tabulce soubor ve formátu *.xlsx pro Excel 2010 (2007) ke stažení zdarma.

Závěr

Máte jiný způsob řešení? Můžete se pochlubit v komentářích.

Článek byl aktualizován: 01.11.2014 09:23

Odměna

Ušetřil vám tento web čas, peníze? Pomohl vyřešit problém? Jste ochotni poskytnout symbolickou odměnu na další rozvoj? Vybrte si formu odměny, která vám vyhovuje.


Pavel Lasák

Pavel Lasák - autor webu

Microsoft Office (Word, Excel, PowerPoint) se věnuji od roku 2006. Své vědomosti a zkušenosti dávám k dispozici na různých školeních a konzultacích, ale také na tomto webu. K dispozici na tomto webu je mnoho návodu, tipů a triků včetně desítek různých šablon.

   Pavel Lasák LinkedIn Profil    Pavel Lasák Google+ Profil    Pavel Lasák facebook Profil    Pavel Lasák twitter Profil

Doporučte tento článek přátelům

Pokud vám článek pomohl, případně si myslíte, že může pomoci i někomu dalšímu, budu rád když jej sdílením doporučíte přátelům - děkuji:



Komentáře zatím nejsou

Můžete být prvními co zanechají smysluplný komentář.







Sdílejte

Pomohl Vám návod?
Sdílejte na Facebooku, G+
LinkedIn...

Nové články

25.03.2017:
ROUNDUP, ROUNDDOWN - zaokrouhlování

07.04.2017:
Řazení Excel - bug - problém

09.04.2017:
Podmínkové funkce Excel - bug - problém


Newsletter

Přihlaste se odběru novinek a získejte:
Ebook zdarma -
10 kroků ke zvládnutí (Word, Excel, PowerPoint)
Šipka Kniha 3D Více o ebooku ...

TOPlist Licence Creative Commons webarchiv rss XML

Stránky o MS Office (Excel) produktu společnosti Microsoft. Neslouží jako technická podpora.
| Email na autora: pavel.lasak@gmail.com | Copyright © : Pavel Lasák 2004 - 2017 | 8626

Tento web zatím neprošel jazykovou korekturou. Beta verze redakčního systému.