Přeskočit navigaci | Přeskočit na novinky
     

Jste zde: Úvodní stránka » excel » funkce-matematicke » SUMX2PY2-funkce-soucet-souctu-ctvercu-Excel
Microsoft Excel logo

SUMX2PY2 (SUMX2PY2) - funkce součet součtu čtverců v Excel

Videokurzy Excel

Ve spolupráci se SEDUO jsem vytvořil několik videokurzů:

Jak na součet součtu čtverců odpovídajících hodnot ve dvou maticích v Excel.

Podobná funkce SUMX2MY2 (součet rozdílů čtverců).

Úvodem do funkce SUMX2PY2

Jak na součet součtů čtverců (druhá mocnina) odpovídajících hodnot ve dvou maticích v Excelu, aneb praktické využití funkce SUMX2PY2 (v angličtině SUMX2PY2), jednak její použití v listu, možné komplikace, tipy až po využití funkce ve VBA.

Pro přehlednost je rozdělen na kapitoly:


Teorie použití SUMX2PY2

Funkce SUMX2PY2 vypočte součet součtů čtverců odpovídajících hodnot ve dvou maticích, neboli každá dvojice čísel se dá na druhou provede součet a následně se všechny čísla sečtou.

Teorie

Excel funkce SUMX2PY2 - syntaxe argumenty

Syntaxe česky:

SUMX2PY2(pole_x;pole_y)

Syntaxe anglicky:

SUMX2PY2(pole_x,pole_y)

Popis argumentů:

  • pole_x - povinný argument - je první matice či oblast dat
  • pole_y - je druhá matice či oblast dat
Excel funkce SUMX2PY2 - syntaxe argumenty

Poznámky:

Pozor na chybové hodnoty, výsledkem bude chyba. Text (který nelze převést na čísla), nezapočte se.

Základní použití SUMX2PY2

Potřebuji součet součtů čtverců (druhých mocnin) hodnot ve dvou bunkách.

=SUMX2PY2(5;7) ... případně =SUMX2PY2(B9:B10;D9:D10)

Samozdřejmě že lze ověřit ručně, závorky záměrně pro přehlednost.

=(B9^2+D9^2)+(B10^2+D10^2)

Případně maticovým výpočtem (nezapomenout při zadávání Ctrl+Shift+Enter)

{=SUMA(B9:B10^2+D9:D10^2)} Excel funkce SUMX2PY2 - ukázka

Praktické použití SUMX2PY2

Součet součtů mocnin hodnot v matici.

=SUMX2PY2(B5:C6;E5:F6) {=SUMX2PY2(B5:C6;E5:F6)} Excel funkce SUMX2PY2 - ukázka

Chyby v SUMX2PY2

Při nevhodném zadání funkce může výsledek skončit chybou.

  • chybová hodnota - pokud je v oblasti chybová hodnota
  • nečíselné hodnoty - nečíselné hodnoty se nesečtou,
=SUMX2PY2(B6:B9;C6:C9) =SUMX2PY2(B6:B9;C7:C9) =SUMX2PY2(B6:B9;E6:E9) =SUMX2PY2(B6:B9;F6:F9)

Poznámky:

Lze využít pomocné funkce, která spočte počet hodnot v oblasti a počet číselných a pokud se rovnají jde o čísla, pokud se nerovnají bude někde problém, nečíselné hodnoty se vám nesečtou. Využitím KDYŽ způsobím výpis OK, Problém.

... pro kontrolu ... =KDYŽ(POČET(B6:B11)=POČET2(B6:B11);"OK";"Problem") Excel funkce SUMX2PY2 - ukázka

Použití s funkce SUMX2PY2 ve VBA

Vložení do buňky.

Range("D5").Formula = "=SUMX2PY2(B5,C5)" Range("D6").FormulaLocal = "=SUMX2PY2(B6;C6)"

Využití WorksheetFunction

Hodnota = Application.WorksheetFunction.SumX2MY2( _ Range("B5"), Range("C6")) MsgBox (Hodnota) Excel funkce SUMX2PY2 - ukázka

Související články s SUMX2PY2

Další články související se statistickými funkcemi:


Microsoft Excel VBA - stahuj logo

Ke stažení ukázka SUMX2PY2

Soubor v přípravě.


Závěrem

Využíváte nějaký trik s funkci SUMX2PY2, můžete zmínit v komentářích.

Článek byl aktualizován: 13.08.2018 15:51

Odměna

Ušetřil vám tento web čas, peníze? Pomohl vyřešit problém? Jste ochotni poskytnout symbolickou odměnu na další rozvoj? Vybrte si formu odměny, která vám vyhovuje.


Pavel Lasák - autor webu

Pavel Lasák

Microsoft Office (Word, Excel, Google tabulky, PowerPoint) se věnuji od roku 2000 (od 2004 na této doméně) - V roce 2017 jsem od Microsoft získal prestižní ocenění MVP (zatím jsem jediný z ČR v kategorií Excel). Své vědomosti a zkušenosti dávám k dispozici i on-line ve videích pro SEDUO. Ve firmách školím a konzultuji, učím na MUNI. Tento web již tvořím přes 15 let. Zdarma je zde přes 1.000 návodu, tipů a triků, včetně přes 250 různých šablon, sešitů.

   Pavel Lasák LinkedIn Profil    Pavel Lasák Google+ Profil    Pavel Lasák facebook Profil    Pavel Lasák twitter Profil


Komentáře zatím nejsou

Můžete být prvními co zanechají smysluplný komentář.






Excel


Sdílejte

Pomohl Vám návod?
Sdílejte na Facebooku, G+
LinkedIn...

Nové články


Reklama


TOPlist Licence Creative Commons webarchiv rss XML

Stránky o MS Office (Excel) produktu společnosti Microsoft. Neslouží jako technická podpora.
| Email na autora: pavel.lasak@gmail.com | Copyright © : Pavel Lasák 2004 - 2019 | 328

Tento web zatím neprošel jazykovou korekturou. Beta verze redakčního systému.