Přeskočit navigaci | Přeskočit na novinky
     

Jste zde: Úvodní stránka » excel » funkce-matematicke » SUMA-CTVERCU-SUMSQ-soucet-ctvercu-argumentu-Excel
Microsoft Excel logo

SUMA.ČTVERCŮ (SUMSQ) - funkce součet čtverců argumentu v Excel

Videokurzy Excel

Ve spolupráci se SEDUO jsem vytvořil několik videokurzů:

Jak na součet čtverců argumentů v Excel.

Úvodem do funkce SUMA.ČTVERCŮ

Jak na součet čtverců v Excelu, aneb praktické využití funkce SUMA.ČTVERCŮ (v angličtině SUMSQ), jednak její použití v listu, možné komplikace, tipy až po využití funkce ve VBA.

Pro přehlednost je rozdělen na kapitoly:


Teorie použití SUMA.ČTVERCŮ

Funkce SUMA.ČTVERCŮ vypočte součet čtverců argumentů, neboli každé číslo se dá na druhou a následně se všechny čísla sečtou.

Teorie

Excel funkce SUMA.ČTVERCŮ - syntaxe argumenty

Syntaxe česky:

SUMA.ČTVERCŮ(číslo1;[číslo2];...)

Syntaxe anglicky:

SUMSQ(číslo1;[číslo2];...)

Popis argumentů:

  • číslo1 - povinný argument - jehož druhé mocniny chcete sečíst (v argumentu nemusí být jen číslo, odkaz na číslo, ale oblast, matice čísel)
  • číslo2, ... - nepovinný argument - jehož druhé mocniny chcete sečíst, až 30 argumentů
Excel funkce SUMA.ČTVERCŮ - syntaxe argumenty

Poznámky:

Pozor na chybové hodnoty, text (který nelze převést na čísla) - výsledkem bude chyba.

Základní použití SUMA.ČTVERCŮ

Potřebuji součet čtverců (druhých mocnin) hodnot v tabulce.

=SUMA.ČTVERCŮ(5) =SUMA.ČTVERCŮ(2;2)

Samozřejmě že lze ověřit ručně

=2^2+2^2

Případně maticovým výpočtem (nezapomenout při zadávání Ctrl+Shift+Enter)

{=SUMA(B15:C15^2)} Excel funkce SUMA.ČTVERCŮ - ukázka

Praktické použití SUMA.ČTVERCŮ

Součet mocnin hodnot v matici.

=SUMA.ČTVERCŮ(B5:C6) {=SUMA.ČTVERCŮ(B5:C6)} =SUMA.ČTVERCŮ(E5:F6) {=SUMA.ČTVERCŮ(E5:F6)} Excel funkce SUMA.ČTVERCŮ - ukázka

Chyby v SUMA.ČTVERCŮ

Při nevhodném zadání funkce může výsledek skončit chybou.

  • chybová hodnota - pokud je v oblasti chybová hodnota
  • nečíselné hodnoty - nečíselné hodnoty se nesečtou,

Poznámky:

Lze využít pomocné funkce, které spočtou počet hodnot v oblasti a počet číselných hodnot ve stejné oblasti a pokud se rovnají je možno funkci zpracovat, pokud se nerovnají, bude někde problém, nečíselné hodnoty se vám ve funkci nesečtou.

=SUMA.ČTVERCŮ(B6:B10) ... pro kontrolu ... =KDYŽ(POČET(B6:B11)=POČET2(B6:B11);"OK";"Problem") Excel funkce SUMA.ČTVERCŮ - ukázka

Použití s funkce SUMA.ČTVERCŮ ve VBA

Vložení do buňky.

Range("D5").Formula = "=SUMSQ(B5,C5)" Range("D6").FormulaLocal = "=SUMA.ČTVERCŮ(B6;C6)"

Využití WorksheetFunction

Hodnota = Application.WorksheetFunction.SumSq(2) MsgBox (Hodnota) Excel funkce SUMA.ČTVERCŮ - ukázka

Související články s SUMA.ČTVERCŮ

Další články související se statistickými funkcemi:


Microsoft Excel VBA - stahuj logo

Ke stažení ukázka SUMA.ČTVERCŮ

Soubor v přípravě.


Závěrem

Využíváte nějaký trik s funkci SUMA.ČTVERCŮ, můžete zmínit v komentářích.

Článek byl aktualizován: 12.08.2018 21:49

Odměna

Ušetřil vám tento web čas, peníze? Pomohl vyřešit problém? Jste ochotni poskytnout symbolickou odměnu na další rozvoj? Vybrte si formu odměny, která vám vyhovuje.


Pavel Lasák - autor webu

Pavel Lasák

Microsoft Office (Word, Excel, Google tabulky, PowerPoint) se věnuji od roku 2000 (od 2004 na této doméně) - V roce 2017 jsem od Microsoft získal prestižní ocenění MVP (zatím jsem jediný z ČR v kategorií Excel). Své vědomosti a zkušenosti dávám k dispozici i on-line ve videích pro SEDUO. Ve firmách školím a konzultuji, učím na MUNI. Tento web již tvořím přes 15 let. Zdarma je zde přes 1.000 návodu, tipů a triků, včetně přes 250 různých šablon, sešitů.

   Pavel Lasák LinkedIn Profil    Pavel Lasák Google+ Profil    Pavel Lasák facebook Profil    Pavel Lasák twitter Profil


Komentáře zatím nejsou

Můžete být prvními co zanechají smysluplný komentář.






Excel


Sdílejte

Pomohl Vám návod?
Sdílejte na Facebooku, G+
LinkedIn...

Nové články


Reklama


TOPlist Licence Creative Commons webarchiv rss XML

Stránky o MS Office (Excel) produktu společnosti Microsoft. Neslouží jako technická podpora.
| Email na autora: pavel.lasak@gmail.com | Copyright © : Pavel Lasák 2004 - 2019 | 513

Tento web zatím neprošel jazykovou korekturou. Beta verze redakčního systému.