Přeskočit navigaci | Přeskočit na novinky
     

Jste zde: Úvodní stránka » excel » funkce-informace » CHYBA-TYP-ERROR-TYPE-cislo-chyby-Excel
Microsoft Excel logo

CHYBA.TYP (ERROR.TYPE) - číslo chyby v Excel

Videokurzy Excel

Ve spolupráci se SEDUO jsem vytvořil několik videokurzů:

Zjistí číslo chyby v buňce.

Úvodem do funkce CHYBA.TYP

Zjištění čísla na základě druhu (kategorie) chyby, aneb praktické využití funkce CHYBA.TYP (v angličtině ERROR.TYPE), jednak teorie, základní použití v listu, praktické příklady, možné komplikace, tipy triky až po využití funkce ve VBA.

Pro přehlednost je článek rozdělen na kapitoly:


Teorie použití CHYBA.TYP

Funkce jen zobrazí číslo, v případě, že výsledkem funkce je chyba nebo se funkce na chybovou hodnotu v buňce odkazuje.

Syntaxe česky:

CHYBA.TYP(chyba)

Syntaxe anglicky:

ERROR.TYPE(chyba)

Popis argumentů:

  • Číslo - povinný argument - je typ chyby, jejíž číslo chcete zjistit

Čísla a typy chyb

  • 1 #NULL!- #NULL!
  • 2 #DĚLENÍ_NULOU! - #DIV/0!
  • 3 #HODNOTA! - #VALUE!
  • 4 #ODKAZ! - #REF!
  • 5 #NÁZEV? - #NAME?
  • 6 #ČÍSLO! - #NUM!
  • 7 #NENÍ_K_DISPOZICI - #N/A
  • 8 #NAČÍTÁNÍ_DAT - #GETTING_DATA
Excel funkce CHYBA.TYP - syntaxe argumenty

Poznámky

Od Excel 2010 se chyby překládají do češtiny. Takže další komplikace. Ale je to můj názor, že stejně jako u funkci, je překládaní nesmysl. Mělo zůstat v angličtině.

Tip

Funkce kontroluje výsledek v buňce, ale dívá se na text. Proto stačí do buňky napsat třeba #NULL! a funkce už řekne číslo chyby. Ač ve skutečnosti v buňce je text, to že ten text je stejný jako označení chyby může být náhoda ;)

Základní použití CHYBA.TYP

Pro chyby zjistěte číslo dané chyby.

=CHYBA.TYP(B5) Excel funkce CHYBA.TYP - ukázka

Vygenerovat chyby

Pro testování je vhodné umět chyby vygenerovat. Vím že se generovat nemusí a stačí název chyby zapsat do buňky, ale když chcete "čistější" řešení ;). Třeba se bude školitelům hodit ;) Mi se hodí tak ať máte pokupě.

=POLÍČKO("test";(A1:A5 C3:C3)) =10/0 =SVYHLEDAT(D3:E7;2;2) =A1+"AHOJ" =DENTÝDNE(B5;B6) =List2!B2+#ODKAZ!B5 =List4!B2 =SUMA(A1;AHOJ) =SUMMA(A1) =MÍRA.VÝNOSNOSTI(C2:C6) =VYHLEDAT(2;B4:C6;3) =NEDEF() Excel funkce CHYBA.TYP - ukázka

Praktické použití CHYBA.TYP

Při zjištění chyby je potřeba vypsat českou hlášku o kterou chybu jde. Lze využít funkci SVYHLEDAT. Za předpokladu, že je k dispozici tabulka, číslo chyby, a jaký text pro danou chybu chci zobrazit.

=SVYHLEDAT(CHYBA.TYP(B18);$B$8:$C$15;2;NEPRAVDA) Excel funkce CHYBA.TYP - ukázka

Tip

Může se použít i s funkci IFERROR, atd.

Chyby v CHYBA.TYP

Při nevhodném zadání funkce může výsledek skončit chybou.

  • #NENÍ_K_DISPOZICI - pokud v buňce není chybová hodnota
=CHYBA.TYP(B7) ošetření pokud není o chybu, ať se nevypíše chyba: =IFERROR(CHYBA.TYP(B12);B12) Excel funkce CHYBA.TYP - ukázka

Tip

Může se použít i s funkci IFERROR, atd.

Použití s funkce CHYBA.TYP ve VBA

Využití CHYBA.TYP ve VBA při zápisu do buňky:

Range("C5").Formula = "=ERROR.TYPE(B5)" Range("C6").FormulaLocal = "=CHYBA.TYP(B6)" Excel funkce CHYBA.TYP - ukázka

Související články s CHYBA.TYP

Další články související s funkcemi informace:


Microsoft Excel VBA - stahuj logo

Ke stažení ukázka CHYBA.TYP

Soubor v přípravě.


Závěrem

Využíváte nějaký trik s funkci CHYBA.TYP, můžete zmínit v komentářích.

Článek byl aktualizován: 26.07.2018 22:16

Odměna

Ušetřil vám tento web čas, peníze? Pomohl vyřešit problém? Jste ochotni poskytnout symbolickou odměnu na další rozvoj? Vybrte si formu odměny, která vám vyhovuje.


Pavel Lasák - autor webu

Pavel Lasák

Microsoft Office (Word, Excel, Google tabulky, PowerPoint) se věnuji od roku 2000 (od 2004 na této doméně) - V roce 2017 jsem od Microsoft získal prestižní ocenění MVP (zatím jsem jediný z ČR v kategorií Excel). Své vědomosti a zkušenosti dávám k dispozici i on-line ve videích pro SEDUO. Ve firmách školím a konzultuji, učím na MUNI. Tento web již tvořím přes 15 let. Zdarma je zde přes 1.000 návodu, tipů a triků, včetně přes 250 různých šablon, sešitů.

   Pavel Lasák LinkedIn Profil    Pavel Lasák Google+ Profil    Pavel Lasák facebook Profil    Pavel Lasák twitter Profil


Komentáře zatím nejsou

Můžete být prvními co zanechají smysluplný komentář.







Sdílejte

Pomohl Vám návod?
Sdílejte na Facebooku, G+
LinkedIn...

Nové články


TOPlist Licence Creative Commons webarchiv rss XML

Stránky o MS Office (Excel) produktu společnosti Microsoft. Neslouží jako technická podpora.
| Email na autora: pavel.lasak@gmail.com | Copyright © : Pavel Lasák 2004 - 2018 | 159

Tento web zatím neprošel jazykovou korekturou. Beta verze redakčního systému.