Přeskočit navigaci | Přeskočit na novinky
     

Jste zde: Úvodní stránka » excel » funkce-informace » ISFORMULA-jde-o-funkci-Excel
Microsoft Excel logo

ISFORMULA (ISFORMULA) - jde o funkci - Excel

Videokurzy Excel

Ve spolupráci se SEDUO jsem vytvořil několik videokurzů:

Funkce ISFORMULA vrátí PRAVDA (TRUE) pokud se v odkazu nachází funkce.

Funkce k dispozici od Excel 2013

Úvodem do funkce ISFORMULA

Jak zjistit, zda v buňce je či není funkce. Lze s využitím Excelu, kdy obdržíte logickou hodnotu PRAVDA, pokud se v buňce nachází funkce/vzorec. Jak na praktické využití funkce ISFORMULA (v angličtině ISFORMULA), od teorie, přes základní použití v listu, praktické příklady, možné komplikace, tipy až po využití funkce ve VBA se dozvíte v tomto článku.

Pro přehlednost je článek rozdělen na kapitoly:


Teorie použití ISFORMULA

Chcete-li zjistit, zda hodnota v buňce je výsledkem funkce musíte využít funkci ISFORMULA. Pokud odkaz (argument) obsahuje funkci vrátí funkce logickou hodnotu PRAVDA. PRAVDA se vrátí i v případě že výsledkem funkce je chybová hodnota.

Syntaxe česky:

ISFORMULA(odkaz)

Syntaxe anglicky:

ISFORMULA(odkaz)

Popis argumentů:

  • odkaz - povinný argument - odkaz na buňku u které potřebujete zjistit zda obsahuje funkci. Odkazem se rozumí odkaz na buňku, nebo definovaný název, který odkazuje na buňku.
Excel funkce ISFORMULA - syntaxe argumenty

Poznámky

Funkci nezajímá výsledek, ale zda v dané buňce je výpočet, pokud je tak vrátí pravdu i kdyby výsledkem funkce/výpočtu byla chybová hodnota.

Základní použití ISFORMULA

U čísel zjisti zda jde o sudá.

=ISFORMULA(B7) =ISFORMULA(B8) =ISFORMULA(B9) =ISFORMULA(B10) Excel funkce ISFORMULA - ukázka

Praktické použití ISFORMULA

Využívám při vypisování vzorců. Ve spojení s funkcemi FORMULATEXT a KDYŽ. Pokud je v buňce vzorec, tak se vzorec vypíše v opačném případě funkce KDYŽ vypíše že v buňce se vzorec nenachází.

=KDYŽ(ISFORMULA(B6);FORMULATEXT(B6);"Není vzorec") Excel funkce ISFORMULA - ukázka

Praktické použití ISFORMULA v maticovém zápisu

Použití funkce v maticovém zápisu. Ve spojení s funkci SUMA a KDYŹ.

{=SUMA(KDYŽ(ISFORMULA(B5:B8);1;0))} Excel funkce ISFORMULA - ukázka

Poznámky

Nezapomenout při zadávání funkce na to, že jde o maticový vzorec. Ctrl + Shift + Enter.

ISFORMULA podmíněné formátování

Funkce ISFORMULA lze využít i v podmíněném formátování, pokud někdo v tabulce přepíše funkci a vloží výsledek ručně. Podmíněné formátování danou buňku podbarví.

Excel funkce ISFORMULA - ukázka

Stačí jen správně nastavit podmíněné formátování.

Excel funkce ISFORMULA - ukázka

Poznámky

Chci mít označeny buňky neobsahujíci vzorec, proto neguji využitím funkce NE.

Chyby v ISFORMULA

Při nevhodném zadání funkce ISFORMULA, může výsledek skončit chybou, nebo vrátí něco jiné než chcete.

  • #NÁZEV? - není správně zadán odkaz na buňku
  • #ODKAZ! - v případě ztráty reference, například odstraněním buňky na kterou se funkce odkazuje
=ISFORMULA(pokus) Excel funkce ISFORMULA - ukázka

Použití s funkce ISFORMULA ve VBA

Využití VBA pro funkci ISFORMULA s využitím WorksheetFunction. výsledek je True nebo False i když jde o češtinu! Jde o VBA.

Hodnota = WorksheetFunction.IsFormula(Range("C6")) MsgBox (Hodnota)

Využití VBA pro funkci ISFORMULA s vložením do listu za využití Formula a FormulaLocal (využití FormulaLocal nedoporučuji, uvádím jen pro dokreslení).

Range("C5").Formula = "=ISFORMULA(B5)" Range("C6").FormulaLocal = "=ISFORMULA(B6)"

Další možnost - zjistit vlastnost přes HasFormula. Za tip díky Petr Pecháček.

Hodnota = Range("B4").HasFormula MsgBox (Hodnota) Hodnota = Range("B5").HasFormula MsgBox (Hodnota)

Pokud máte starší verzi Excel můžete si vytvorřit vlastní funkci ;) Která zjistí zda odkaz obsahuje vzorec. Nezapomenout vložit do Module.

Function JeVzorec(ByVal odkaz As Range) As Boolean JeVzorec = odkaz.HasFormula End Function Excel funkce ISFORMULA - ukázka

Související články s ISFORMULA

Další články související funkci:


Microsoft Excel - stahuj logo

Ke stažení ukázka ISFORMULA

Soubor jak prakticky využít funkci ISFORMULA v přípravě.


Závěrem

Využíváte nějaký trik s funkci ISFORMULA, případně kde a jak využíváte, můžete zmínit v komentářích.

Článek byl aktualizován: 30.07.2018 07:54

Odměna

Ušetřil vám tento web čas, peníze? Pomohl vyřešit problém? Jste ochotni poskytnout symbolickou odměnu na další rozvoj? Vybrte si formu odměny, která vám vyhovuje.


Pavel Lasák - autor webu

Pavel Lasák

Microsoft Office (Word, Excel, Google tabulky, PowerPoint) se věnuji od roku 2000 (od 2004 na této doméně) - V roce 2017 jsem od Microsoft získal prestižní ocenění MVP (zatím jsem jediný z ČR v kategorií Excel). Své vědomosti a zkušenosti dávám k dispozici i on-line ve videích pro SEDUO. Ve firmách školím a konzultuji, učím na MUNI. Tento web již tvořím přes 15 let. Zdarma je zde přes 1.000 návodu, tipů a triků, včetně přes 250 různých šablon, sešitů.

   Pavel Lasák LinkedIn Profil    Pavel Lasák Google+ Profil    Pavel Lasák facebook Profil    Pavel Lasák twitter Profil


Komentáře zatím nejsou

Můžete být prvními co zanechají smysluplný komentář.







Sdílejte

Pomohl Vám návod?
Sdílejte na Facebooku, G+
LinkedIn...

Nové články


TOPlist Licence Creative Commons webarchiv rss XML

Stránky o MS Office (Excel) produktu společnosti Microsoft. Neslouží jako technická podpora.
| Email na autora: pavel.lasak@gmail.com | Copyright © : Pavel Lasák 2004 - 2018 | 523

Tento web zatím neprošel jazykovou korekturou. Beta verze redakčního systému.