Přeskočit navigaci | Přeskočit na novinky
     

Jste zde: Úvodní stránka » excel » funkce-vyhledavaci » NEPRIMY-ODKAZ-INDIRECT-prakticky-Excel
Microsoft Excel logo

NEPŘÍMÝ.ODKAZ (INDIRECT) - prakticky Excel

Videokurzy Excel

Ve spolupráci se SEDUO jsem vytvořil několik videokurzů:

Jak prakticky využít NEPŘÍMÝ.ODKAZ (INDIRECT) v Excel.

Předpokládám základní znalost funkce NEPŘÍMÝ.ODKAZ (INDIRECT) aneb co se do 11 ukázek v článku nevešlo.

Obsah

Abych mohl k ukázkám přidávat a pro jednodušší hledání je článek rozdělen na kapitoly. Nechce se mi pro každou ukázku tvořit samostatný článek (to by jich na webu již bylo přes 10.000 místo přes 1000 ;) navíc se mi v "kumulovaných" článcích lépe hledá:


Napadá vás nějaké další použití, můžete zmínit v komentářích.

1) Dynamická změna rozsahu pro agregační funkce např. SUMA >

Mám tabulku, kde průběžně přibývají hodnoty a já chci mít SUMU (případně jinou agregační hodnotu z automaticky přibývajících hodnot). Navíc nemohu (nechci využít tabulku jako Tabulka, případně nemohu označit celý sloupec).

Mohu využít funkci POČET (COUNT), která zjistí počet hodnot (případně připočíst posunutí, pokud tabulka nezačíná od prvního řádku.

=POČET(C7:C25)+4 =SUMA(NEPŘÍMÝ.ODKAZ("C5:C"&E7)) =SUMA(C7:NEPŘÍMÝ.ODKAZ("C"&E7)) ' pokud nechci mít funkci POČET v pomocné buňce =SUMA(NEPŘÍMÝ.ODKAZ("C5:C"&POČET(C7:C25)+4))

Tip

Nádherně lze použit v ověření dat ve spojení s POSUN.

Použití ve spojení s PRŮMĚR, MEDIÁN, atd.

Ukázka

Excel NEPŘÍMÝ.ODKAZ  (INDIRECT) - agregační funkce

2) Využití definovaných názvů pro konstanty

Mám tabulku s kurzy (může se jednat o slevy, atd.). Buňky obsahující kurzy mám pojmenovaný využitím definovaného názvu. Následně se pak mohu na tyto definované názvy (konstanty) odkázat na základě sloupce.

Navíc ze sloupce si mohu údaj vzít textovou funkcí pokud jsou názvy sloupců dobře vytvořeny.

=C6*NEPŘÍMÝ.ODKAZ("Kurz"&ZPRAVA($C$5;3))

Ukázka

Excel NEPŘÍMÝ.ODKAZ  (INDIRECT) - konstanty

3) Vyhledávaní v tabulkách s definovanou oblastí

Mám několik tabulek a na základě výběru názvy tabulky a jedinečné hodnoty v prvním sloupci, potřebuji získat příslušnou hodnotu z dalšího sloupce.

Pokud nechci využít Tabulka jako tabulka (což jsme popsal jinde - Tabulka jako tabulka a NEPŘIMÝ.ODKAZ)

=SVYHLEDAT(E11;NEPŘÍMÝ.ODKAZ($F$11);2;NEPRAVDA)

Tip

Vytvořit jako Tabulka s NEPŘIMÝ.ODKAZ

Pokud se člověk zamyslí, může tabulky lépe pojmenovat, podle významu, navíc pokud pojde o tabulku jako Tabula, lze se na jednotlivé sloupce elegantněji odkazovat.

Ukázka

Excel NEPŘÍMÝ.ODKAZ  (INDIRECT) - definované oblasti

4) Vyhledávaní v tabulce, znám řádek a sloupec

Mám tabulku a na základě zadaného řádku a sloupce potřebuji získat patřičnou hodnotu na daném průsečíků.

Mou jít na to dvěma způsoby, přes R1C1 odkazování (číslo řádku mám napřímo a hned), nebo využít A1 odkazování, kdy si přes funkci ZNAK "pomohu" se získáním písmena patřičného sloupce (pro A - Z).

=NEPŘÍMÝ.ODKAZ("R"&D16+6&"C"&D17+1;NEPRAVDA) =NEPŘÍMÝ.ODKAZ(E17&D16+6)

Tip

Samozřejmě nezapomenu započíst posunutí řádku a sloupce, pokud tabulka nezačíná v A1 (R1C1).

Ukázka

Excel NEPŘÍMÝ.ODKAZ  (INDIRECT) - hledání v tabulce. řádek a sloupec
v

5) Spojit data z více listů do jedne tabulky

Potřebuji propojit data za 54 týdnu, nebo 12 měsíců. Data jsou ve stejných buňkách a potřebuji je dostat do jendoho listu, bohužel jsou po listě rozházeny F6:F9, G11:G12 atd.

Ukázka

Excel NEPŘÍMÝ.ODKAZ  (INDIRECT) - data zdroj

Jak na to

Vím jak jsou pojmenovány listy (01 ... 12 ..54), tak jejich názvy umístím do řádku, odkazy na konkrétní buňky zapíši do sloupce (je mi poté jedno na kterých místech se nacházejí, jedna buňka jeden odkaz) a pak jen spojím využítím NEPŘÍMÝ.ODKAZ (INDIRECT). Rozkopíruji a mám hotovo.

=NEPŘÍMÝ.ODKAZ("'" & G$6 & "'!" & $F7)

Ukázka řešení

Excel NEPŘÍMÝ.ODKAZ  (INDIRECT) - agregace z více tabulek

Související články s funkci HYPERTEXTOVÝ.ODKAZ

Další články související s vyhledávacími funkcemi:


/

Závěrem

Napadá vás tip na dolnění? Jak využívate funkci NEPŘIMÝ.ODKAZ, můžete zmínit v komentářích.

Článek byl aktualizován: 26.03.2019 15:01

Odměna

Ušetřil vám tento web čas, peníze? Pomohl vyřešit problém? Jste ochotni poskytnout symbolickou odměnu na další rozvoj? Vybrte si formu odměny, která vám vyhovuje.


Pavel Lasák - autor webu

Pavel Lasák

Microsoft Office (Word, Excel, Google tabulky, PowerPoint) se věnuji od roku 2000 (od 2004 na této doméně) - V roce 2017 jsem od Microsoft získal prestižní ocenění MVP (zatím jsem jediný z ČR v kategorií Excel). Své vědomosti a zkušenosti dávám k dispozici i on-line ve videích pro SEDUO. Ve firmách školím a konzultuji, učím na MUNI. Tento web již tvořím přes 15 let. Zdarma je zde přes 1.000 návodu, tipů a triků, včetně přes 250 různých šablon, sešitů.

   Pavel Lasák LinkedIn Profil    Pavel Lasák Google+ Profil    Pavel Lasák facebook Profil    Pavel Lasák twitter Profil


Komentáře zatím nejsou

Můžete být prvními co zanechají smysluplný komentář.






Excel


Sdílejte

Pomohl Vám návod?
Sdílejte na Facebooku, G+
LinkedIn...

Nové články


Reklama


TOPlist Licence Creative Commons webarchiv rss XML

Stránky o MS Office (Excel) produktu společnosti Microsoft. Neslouží jako technická podpora.
| Email na autora: pavel.lasak@gmail.com | Copyright © : Pavel Lasák 2004 - 2019 | 721

Tento web zatím neprošel jazykovou korekturou. Beta verze redakčního systému.