Přeskočit navigaci | Přeskočit na novinky
     

Jste zde: Úvodní stránka » excel » prakticke-priklady » pt100-teplota-prepocty-excel

Pt 100 - teplota - Pt100 přepočty Excel

Videokurzy Excel

Ve spolupráci se SEDUO jsem vytvořil několik videokurzů:

Jak přepočítávat teplotu na odpor Pt100 a odpor Pt100 na teplotu.

Úvodem

Jelikož sem tam potřebuji v práci přepočítat odpor Pt 100 na teplotu a obráceně rozhodl jsem se do práce si vytvořit pomocnou sešit v Excelu. Dva vrorečky, zatám hodnotu a druhá (požadovaná) se dopočte.

Co tedy bude převádět:

Doplňky

Pt100 - teplota - pt100 MS Excel 2010

Teorie

Teorie je popsána na Wikipedií (aneb odkud jsem čerpal informace). Resistance thermometer.

Koeficienty:

Pro výpočet budou potřeba tyto koeficienty:

  • koeficient A 0,0039083
  • koeficient B -0,0000005775
  • koeficient C -0,000000000004183

Teplota na Pt100

Pozor dva vzorce do nuly a nad nulu.

=KDYŽ(B12<0;100*(1+$C$6*K17+$C$7*(K17^2)+$C$8*(K17^3)*(K17-100));100*(1+$C$6*B12+$C$7*(B12^2)))

Poznámka: Vzorec platí pro výše zobrazený sešit.

Pt100 na teplotu

Použijte tento vzorec

=(ODMOCNINA($C$7*E12-100*$C$7+25*$C$6^2)-5*$C$6)/(10*$C$7)

Poznámka: Vzorec platí pro výše zobrazený sešit.

Ke stažení

Soubor převod Pt100 na teplotu a zpět soubor ve formátu *.xls ke stažení zdarma.

Zpět na seznam kapitol.

Možné doplňky "převodníku"

Ze vzorce můžete ve VBA vytvořit vlastní funkci, doplnit výpočty i pro Pt 1000 atd...

Toto již nechám na Vás - jako domácí úkol ;-)

Zpět na seznam kapitol.

Závěrem

Jak převádíte Pt100 na teplotu a opačně? Využíváte papírovou tabulku, nebo vlastní výpočet v Excelu?

Článek byl aktualizován: 01.11.2014 12:59

Odměna

Ušetřil vám tento web čas, peníze? Pomohl vyřešit problém? Jste ochotni poskytnout symbolickou odměnu na další rozvoj? Vybrte si formu odměny, která vám vyhovuje.


Pavel Lasák

Pavel Lasák - autor webu

Microsoft Office (Word, Excel, PowerPoint) se věnuji od roku 2006. Své vědomosti a zkušenosti dávám k dispozici na různých školeních a konzultacích, ale také na tomto webu. K dispozici na tomto webu je mnoho návodu, tipů a triků včetně desítek různých šablon.

   Pavel Lasák LinkedIn Profil    Pavel Lasák Google+ Profil    Pavel Lasák facebook Profil    Pavel Lasák twitter Profil

Doporučte tento článek přátelům

Pokud vám článek pomohl, případně si myslíte, že může pomoci i někomu dalšímu, budu rád když jej sdílením doporučíte přátelům - děkuji:



Komentáře


Michal

Přidáno: 07.09.16 15:20

Dobry den, muzu se zeptat co je to cislo "25" ve vzorci Pt na teplotu?







Sdílejte

Pomohl Vám návod?
Sdílejte na Facebooku, G+
LinkedIn...

Nové články

25.03.2017:
ROUNDUP, ROUNDDOWN - zaokrouhlování

07.04.2017:
Řazení Excel - bug - problém

09.04.2017:
Podmínkové funkce Excel - bug - problém


Newsletter

Přihlaste se odběru novinek a získejte:
Ebook zdarma -
10 kroků ke zvládnutí (Word, Excel, PowerPoint)
Šipka Kniha 3D Více o ebooku ...

TOPlist Licence Creative Commons webarchiv rss XML

Stránky o MS Office (Excel) produktu společnosti Microsoft. Neslouží jako technická podpora.
| Email na autora: pavel.lasak@gmail.com | Copyright © : Pavel Lasák 2004 - 2017 | 11519

Tento web zatím neprošel jazykovou korekturou. Beta verze redakčního systému.