Přeskočit navigaci | Přeskočit na novinky
     

Jste zde: Úvodní stránka » excel » nastroje » zamykani-bunek-excel-2010

Zamykání buněk - Excel 2010

Videokurzy Excel

Ve spolupráci se SEDUO jsem vytvořil několik videokurzů:

... co není zamčeno, uživatel přepíše ... aneb jak si zabezpečit šablony v Excel

Doplněno 3.5.2015

Úvodem do zamykání buněk

Tvoříte své šablony? Chcete je ještě více vylepšit? Využijte možnost zamykání buněk. V tomto článku se dozvíte:

Proč zamykání buněk v Excelu

Pro složitější Excelovské tabulky se hodí zamknout nepoužívané buňky. Uživatel je nemůže nechtěně (chtěně) přepsat. Pokud máte najednou otevřeno více oken, může se Vám stát nechtěné přepsání (přiznávám se, mě se to stává(lo) – hlavně při používání klávesových zkratek Ctrl+C – Ctrl+V).

Jak zamykat/odemykat/přepsat zamknutý list pomocí VBA jsem sepsal v článku Zamykání/odemykání buněk - Protect/Unprotect - Excel VBA

Nastavení buněk pro změny

Jak některé buňky nechat odemknuty?

Excel má v základu nastaveno všechny buňky připraveny pro zamknutí. Proto každou buňku, kterou chcete nechat uživateli přístupnou pro změnu, musíte nejprve nastavit. Přes kartu Domů Skupina – Buňky – Formát... - Formát buněk.

MS Excel 2010 - zamykání buněk

V zobrazeném okně Formát buněk zvolíme kartu Zámek.

MS Excel 2010 - zamykání buněk

V případě že chceme uživateli povolit do buňky zápis, musí být nezaškrtnuto (odškrtnout políčko Uzamknout). Poznámka: Jako standart je nastaveno, že všechny buňky se zamykají.

Jak zamknout buňky

V Excelu si můžeme zamknout celý jen list, či celý sešit. Na kartě Revize ve skupině Změny, vybereme Zamknout list.

MS Excel 2010 - zamykání buněk

Poznámka: pokud nic nenastavíme, máme zamčeno vše, všechny buňky.

Uzamknout list

V zobrazeném okně můžeme nastavit podrobněji, co a jak chceme zamknout. Další možností, kterou máme je nastavení hesla pro lepší zabezpečení.

MS Excel 2010 - zamykání buněk

Poznámka: Osobně hesla nepoužívám, člověk zapomene a poté má problémy se změnou.

Oznámení o zamknutí

Pokud se pokusíte změnit zamknutou buňku, Excel ohlásí chybovou hlášku o tom, že buňka je zamknutá.

MS Excel 2010 - zamykání buněk

Jak odemknout buňky

V Excelu si můžeme odemknout celý jen list, či celý sešit. Na kartě Revize ve skupině Změny, vybereme Odemknout list.

MS Excel 2010 - zamykání buněk

Poznámka: Pokud bylo nastaveno heslo při zamykání, budete požádaní o jeho zadání.

Bezpečnost zamykání s heslem

Doporučuji nevěřit bezpečnosti zabezpečení sešitu pomocí hesla. Na internetu existuje spousta návodů a programů, které zabezpečení sešitů pomocí hesla dokáží obejít.

Na druhou stranu pokud uživatel má jen základní znalost Excelu, nedokáže odemknout sešit. I když je bez hesla.

Osobně sešity na heslo nezamykám. Nejen, že bych si musel pamatovat hesla, ale jejich nastavení zabere více práce, než daný sešit následně odemknout.

Závěr

Jak jste na tom vy? Využíváte zamykání? Používáte hesla při zamykání listů/sešitů? Můžete se zmínit v komentářích.

Článek byl aktualizován: 03.05.2015 19:05

Odměna

Ušetřil vám tento web čas, peníze? Pomohl vyřešit problém? Jste ochotni poskytnout symbolickou odměnu na další rozvoj? Vybrte si formu odměny, která vám vyhovuje.


Pavel Lasák

Pavel Lasák - autor webu

Microsoft Office (Word, Excel, PowerPoint) se věnuji od roku 2006. Své vědomosti a zkušenosti dávám k dispozici na různých školeních a konzultacích, ale také na tomto webu. K dispozici na tomto webu je mnoho návodu, tipů a triků včetně desítek různých šablon.

   Pavel Lasák LinkedIn Profil    Pavel Lasák Google+ Profil    Pavel Lasák facebook Profil    Pavel Lasák twitter Profil

Doporučte tento článek přátelům

Pokud vám článek pomohl, případně si myslíte, že může pomoci i někomu dalšímu, budu rád když jej sdílením doporučíte přátelům - děkuji:



Komentáře


Helena

Přidáno: 27.09.12 08:55

Zdravím, již druhý den hledám odpověď na: zamknutí buňky pomocí $ Ano, jde mi o jednu buňku. (ne sešit, list, oblast , ..apod.) Děkuji

Pavel Lasák

Přidáno: 27.09.12 19:29

To Helena: Nerozumím otázce. Potřebujete zamknout jen jednu buňku a ostatní nechat odemknuty? Protože $ sepoužívají v buňkách ke změně relativního na absolutní pozicování.

Ája

Přidáno: 16.10.13 16:01

děkuju moc,strašně mi to pomohlo,ptotože z toho máme psát na IVT test a zrovna,když to učitelka vysvětlovala tak jsem nebyla ve škole.Doufám že ten test dopadne dobře.Ještě jednou děkuju :)

Pavel Lasák

Přidáno: 16.10.13 19:14

To Ája: Určitě dopadne dobře, protože už to umíte a navíc držím palce.

peters

Přidáno: 20.11.13 09:25

Dobrý den, co ale v případě, že obě položky (zamknout i odemknout list) jsou nepřístupné (šedé) ? Jak vůbec obecně zjistit v neznámém souboru, co je uzamčeno nebo skryto? Děkuji.

Pavel Lasák

Přidáno: 20.11.13 17:21

To peters: Buď pomocí VBA, nebo podmíněné formátování =POLÍČKO("zámek";A1)=0

Muna

Přidáno: 03.01.14 09:11

Dobrý den, vytvořila jsem tabulku s několika závislýmy seznamy přesně podle vaší tabulky (kapitola závislé seznamy)a všechny buňky pozamykala jak píšete zde. Aby užívatel ale mohl pouze vybírat z rozbalovacích seznamů různé varianty a následně otvírat výsledek - hypertextový odkaz, tak jsem v rozbal.seznamech odznačila políčko "uzamčeno" (formát ovládacího prvku/zámek/uzamčeno. Poté uzamkla s heslem celý list. Přesto mi při kliknutí do rozbalovacího seznamu vyskakuje hláška o zamknutí. Nevíte v čem dělám chybu? musí být odemčeny i zdrojové tabulky pro ty závislé seznamy? Děkuji

Muna

Přidáno: 03.01.14 14:51

už to mám!nemusíte odpovídat.Díky

Dušan

Přidáno: 03.07.14 16:50

Dobrý den. Používám Excel 2007. Vytvořím list, vyberu buňky,které mají zůstat odemčené a celý list zamknu. Při kliknutí na odemknutou buňku zamčeného listu se text, který do této buňky píši nepronáší do Řádku vzorců. Stejně tak pokud v takovéto buňce chci editovat již dříve napsaný obsah musím napsat celé znovu. Lze prosím nastavit aby se odemčená buňka v uzamčeném listu chovala pro popisovanou záležitost stejně jako v odemčeném listu (tedy aby se obsah buňky pronášel do Řádku vzorců). Děkuji.

Robert

Přidáno: 03.09.14 10:16

Dobrý den, lze nějakým způsobem změnit ta chybová hláška: "Pokoušíte se změnit...."? Díky.

Vláďa Pokorný

Přidáno: 08.09.14 13:07

Dobrý den, je možné vymazat jen neuzamknuté buňky, když provedu hromadný výběr, kde jsou jak tedy neuzamknuté, tak i uzamknuté? Hodilo by se mi to na čištění tabulek. Děkuji.

Jojo

Přidáno: 11.09.14 08:09

To Dušan: -- 1) Po odomknutí listu vybrať(vysvietiť) bunky + zrušiť zakliknutie vo "Formát buněk/Zámek/Skrýt vzorce" + zamknúť list

Jojo

Přidáno: 11.09.14 08:46

To Vláďa Pokorný: -- Cez makro:Sub Test() 'Odstrániť vš.otvorené bunky z výberu pri zamknutom liste For Each cell In Selection If Not cell.Locked Then cell.ClearContents Next cell End Sub

Petra

Přidáno: 12.10.14 18:28

Dobrý den, vlastně ahoj :-) můj dotaz se týká odemykání uzamčených souborů: každý zaměstnanec si do vlastního excelovského sešitu zapisuje docházku. Sešity jsem jim vytvořila a naformátovala já, takže jsou jednotné, liší se jen názvem a počtem hodin. Sešity mají uzamčené, aby jenom oni mohli měnit počty hodin, hesla si zvolili sami. Nicméně já ty hesla znám, abych jim do souborů mohla nahlížet. Nyní si vytvářím souhrnnou tabulku, kde se mi součty hodin jednotlivých zaměstnanců automaticky aktualizují a následné s těmito daty provádím další výpočty. Když sešit se souhrnnou tabulkou otevřu nyní, musím zadat hesla všech sešitů, které jsou do ní navázány, aby se mi data aktualizovala. Jde nějak zařídit, abych hesla nemusela pokaždé zadávat? Aby se mi data po odsouhlasení aktualizace automaticky obnovila? Moc děkuji za odpověď!

CZhoumer

Přidáno: 13.10.14 07:50

Brej den. Buňka A1 v "listu1" se odkazuje na na buňku B4 v "listu2". Jinak: v A1 se zobrazuje suma vypočtená v B4. A k určitému datumu (31.12.2014) chci v buňce A1 ukončit zobrazení buňky B4, protože v buňce B4 dojde k novým výpočtům. Prostě, aby se v buňce A1 zobrazila poslední suma 31.12.2014. V další buňce A2 se již bude zobrazovat suma od 1.1.2015. Lze to nějak? Děkuji

Jojo

Přidáno: 14.10.14 08:16

To Petra: -- 1)Vytvoriť zoznam Názov_súborov - Heslá alebo iba Známe_heslá -- 2) Pomocou makra načítavať súbory a použitím hesiel ich otvoriť

Jojo

Přidáno: 14.10.14 08:32

To Pavel Lasák: -- Prosím posúdiť, či môj predchádzajúci príspevok pre Petru neprekračuje hranice tejto stránky! Ak áno, prosím ho vymazať. Ďakujem

Jojo

Přidáno: 14.10.14 08:55

To CZhoumer: -- Do B1 napísať dátum "už nezobrazovať" (napr.1.1.2015), do A1 napísať: =KDYŽ(NYNÍ()

Jojo

Přidáno: 15.10.14 10:35

To CZhoumer: -- ešte raz: =KDYŽ(NYNÍ() =KDYŽ(NYNÍ() (=bez zápisu do B1)

Jojo

Přidáno: 15.10.14 10:46

To CZhoumer: -- 3.pokus:'Ak v B1 bude dátum =KDYŽ(NYNÍ()<B1;List2!B4;"") 'Bez zápisu do B1 =KDYŽ(NYNÍ()<DATUM(2015;1;1);List2!B4;"")

Petra

Přidáno: 23.10.14 13:08

To Jojo: moc děkuji, pomohlo!

Dana

Přidáno: 17.02.15 08:48

Dobrý den, zamkla jsem list v excelu s tím, že některé buňky v tabulce jsem nechala odemčené. Mám v tabulce sloupec s pořadovým číslem řádku, abych mohla řádkům přečíslovávat pořadí a poté je filtrem znovu seřadi. (Jedná se o excel s programem jednání a občas se pořadí témat mění). Po zamčení sešitu a povolení seřadit a použití automatického filtru mi stejně nelze seřadit buňky. (Jak zamčené tak nezamčené) Děkuji za radu.

Martin

Přidáno: 19.02.15 10:18

Dobrý den. S excelem mám spoustu zkušenosti avšak našel jsem problém který nedokážu řešit. Do vytvořeného listu jsem přidával vlastní část tabulky. Všem buňkám jsem dal že budou zamčeny kromě pár buněk které potřebuji. Zamknu list. V mojí části tabulky funguje zamčení jak má ovšem v původní části i přes to že buňky mají nastavené zamknutí a list je zamčen tak do nich jde psát.

Julda

Přidáno: 01.04.15 11:13

Dobrý den! Mám v excel- sešitu několik listů. Po uzamknutí sešitů mi nejdou vkládat komentáře jenom v některých listech. Př. ve dvou zamknutých listech komentáře jdou vložit a v dalších nejdou, přitom mám parametry pro vkládání dat v neuzamčených buňkách nastaveny stejně jako v předešlých listech

Honza

Přidáno: 05.09.15 22:03

Dobrý den, jak automaticky zamknout buňku po zadání aktuálního času zkratkou CTRL+SHIFT+:(dvojtečka). Potřeboval bych to aby nikdo po zadání času již nemohl buňku změnit. Děkuji.

Matěj

Přidáno: 28.10.15 11:01

Dobrý den, děkuji za velmi užitečné stránky a prosím o radu. Mám sešit, ve kterém je cca třetina buněk zamčená. Při zamykání vždy zatrhnu jako povolené akce "Seřadit", "Filtrovat" a další. Po zamčení ale buňky na listu řadit nejde. Potřebuji, aby uživatel neměl možnost zamčené buňky měnit, ale aby zároveň mohl sešit libovolně řadit. Nevíte, jak na to? Díky, Matě

Robert

Přidáno: 30.10.15 08:57

Prosím o radu, ako uzamknúť všetky bunky tabuľky tak, aby ostali funkčné hypertextové odkazy, pri súčasnom znemožnení výberu uzamknutých buniek. Má to byť čiste náhľad bez vyberania buniek, pričom hypertexty by naďalej fungovali. Zaujímavé je, že kurzor sa pri ukázaní na hypertext zmení na ruku, ale kliknutie nefunguje... Ďakujem

Petr

Přidáno: 19.04.16 09:18

Dobry den, jak udelatz, aby v zamknutém listu fungovali souhrny (seskupení). Dekuji

Jirka

Přidáno: 30.06.16 13:29

Dobrý den, prosím o radu: mám excelovský soubor, kde je více listů se stejnými tabulkami. Jde mi o to zda jde nějak udělat to, že zamknu jen některé buňky, ale ve všech listech najednou, abych to nedělal pro každý list zvlášť??? Děkuji za případnou radu.







Sdílejte

Pomohl Vám návod?
Sdílejte na Facebooku, G+
LinkedIn...

Nové články

25.03.2017:
ROUNDUP, ROUNDDOWN - zaokrouhlování

07.04.2017:
Řazení Excel - bug - problém

09.04.2017:
Podmínkové funkce Excel - bug - problém


Newsletter

Přihlaste se odběru novinek a získejte:
Ebook zdarma -
10 kroků ke zvládnutí (Word, Excel, PowerPoint)
Šipka Kniha 3D Více o ebooku ...

TOPlist Licence Creative Commons webarchiv rss XML

Stránky o MS Office (Excel) produktu společnosti Microsoft. Neslouží jako technická podpora.
| Email na autora: pavel.lasak@gmail.com | Copyright © : Pavel Lasák 2004 - 2017 | 46321

Tento web zatím neprošel jazykovou korekturou. Beta verze redakčního systému.