Přeskočit navigaci | Přeskočit na novinky
     

Jste zde: Úvodní stránka » excel » funkce-statisticke » POCET-COUNT-statisticka-funkce-Excel
Microsoft Excel logo

POČET (COUNT) - statistická funkce Excel

Videokurzy Excel

Ve spolupráci se SEDUO jsem vytvořil několik videokurzů:

Počet buněk, které obsahují čísla.

Úvodem do funkce POČET

Jak zjistit počet číselných hodnot ve zvolené oblasti v Excel, aneb využití funkce POČET (v angličtině COUNT), jednak její použití v listu, porovnání s podobnými funkcemi až po využití funkce ve VBA.

Jak na funkci POČET prakticky od A do Z ukazuji v tomto článku, opět pro přehlednost je rozdělen na kapitoly:


Teorie použití POČET

Funkce POČET (v angličtině COUNT) vrátí počet číselných hodnot ze zvolené oblasti (seznamu argumentu).

Syntaxe česky:

POČET(hodnota1; [hodnota2;…])

Syntaxe anglicky:

COUNT(hodnota1; [hodnota2;…])

Popis argumentů:

  • hodnota1, hodnota2, ... - je 1 až 30 argumentů, které mohou obsahovat různé datové typy nebo na ně odkazovat. Počítají se však pouze čísla.

Poznámky:

  • Prázdné buňky, logické hodnoty, text nebo chybové hodnoty se ignorují.
  • Jestliže potřebujete počítat logické hodnoty, texty nebo chybové hodnoty, použijte funkci POČET2.
Excel funkce POČET - COUNT

Základní použití POČET

Mám tabulku s hodnotami a potřebuji zjistit počet číselných hodnot ve zvolené oblasti.

=POČET(B5:B10) Excel funkce POČET - základy

Porovnání POČET

Co funkce POČET započte a co ne? Pro zjednodušení jsem vytvořil tabulku obsahující základní typy hodnot, které můžete mít v buňkách. Pro větší efektivitu je k dispozici porovnání s dalšími podobnými funkcemi.

Excel funkce POČET porovnání

Použití s funkce POČET s využitím VBA

Zápis funkce do buňky:

Range("B8").Formula = "=COUNT(B5:D5)" Range("B8").FormulaLocal = "=POČET(B5:D5)"

Využití WorksheetFunction

HodnotaPocet = Application.WorksheetFunction.Count(1,2,3) MsgBox (HodnotaPocet) Excel funkce POČET porovnání

Související články s funkci POČET

Další články související se statistickými funkcemi:


Microsoft Excel VBA - stahuj logo

Ke stažení

Soubor v přípravě.


Závěrem

Využíváte nějaký trik s funkcí POČET, můžete zmínit v komentářích.

Článek byl aktualizován: 01.01.2017 15:37

Odměna

Ušetřil vám tento web čas, peníze? Pomohl vyřešit problém? Jste ochotni poskytnout symbolickou odměnu na další rozvoj? Vybrte si formu odměny, která vám vyhovuje.


Pavel Lasák - autor webu

Pavel Lasák

Microsoft Office (Word, Excel, PowerPoint) se věnuji od roku 2000 (od 2004 ne této doméně) - Roku 2017 jsem od Microsoft získal prestižní ocenění MVP (zatím jsem jediný z ČR v kategorií Excel). Své vědomosti a zkušenosti dávám k dispozici také na on-line videích pro SEDUO. Školím a konzultuji, učím na MUNI. Hlavně tvořím tento web. Je zde k dispozici přes 1.000 návodu, tipů a triků včetně stovek různých šablon, sešitů.

   Pavel Lasák LinkedIn Profil    Pavel Lasák Google+ Profil    Pavel Lasák facebook Profil    Pavel Lasák twitter Profil


Komentáře zatím nejsou

Můžete být prvními co zanechají smysluplný komentář.







Sdílejte

Pomohl Vám návod?
Sdílejte na Facebooku, G+
LinkedIn...

Nové články


Newsletter

Přihlaste se odběru novinek a získejte:
Ebook zdarma -
10 kroků ke zvládnutí (Word, Excel, PowerPoint)
Šipka Kniha 3D Více o ebooku ...

TOPlist Licence Creative Commons webarchiv rss XML

Stránky o MS Office (Excel) produktu společnosti Microsoft. Neslouží jako technická podpora.
| Email na autora: pavel.lasak@gmail.com | Copyright © : Pavel Lasák 2004 - 2017 | 1706

Tento web zatím neprošel jazykovou korekturou. Beta verze redakčního systému.