Přeskočit navigaci | Přeskočit na novinky
     

Jste zde: Úvodní stránka » excel » funkce-logicke » NEBO-OR-logicka-funkce-Excel
Microsoft Excel logo

NEBO - (OR) - logická funkce Excel

Videokurzy Excel

Ve spolupráci se SEDUO jsem vytvořil několik videokurzů:

Jak využít logickou funkci NEBO (OR) v Excel. Nejen klasické použití, ale jak tuto funkci využít v ověření dat a podmíněném formátování.

Úvodem do funkce NEBO (OR)

Na první pohled funkce NEBO (stejně jako další funkce) moc toho neumí - Vrátí logickou hodnotu PRAVDA, jestliže alespoň jeden z argumentů má hodnotu PRAVDA. Jinak NEPRAVDA. Na ten druhý, když se umí vhodně použít, vaše tabulky jsou interaktivní a práce s nimi je rychlejší (najednou firma šetří desítky minut denně u jedné osoby pracující s Excel) a pohodovější.

Jak na To ukážu v tomto článku, opět pro přehlednost je rozdělen na kapitoly:


Teorie použití A (OR)

Funkce NEBO (v angličtině OR) vrátí hodnotu PRAVDA, pokud alespoň jeden argument je PRAVDA, jinak vrátí hodnotu NEPRAVDA (neboli NEPRAVDA pokud všechny argumenty jsou NEPRAVDA).

Syntaxe česky:

NEBO(loghod1;[loghod2;] ...)

Syntaxe anglicky:

OR(loghod1,[loghod2,] ...)

Popis argumentů:

  • loghod1, loghod2 - může být až 255 testovaných podmínek, které mohou být buď PRAVDA, anebo NEPRAVDA.

Poznámky:

  • Pokud zadaná oblast neobsahuje žádné logické hodnoty, vrátí funkce A chybovou hodnotu #HODNOTA!.
Excel funkce OR

Základní použití funkce NEBO

Co funkce vrátí pro různé logické hodnoty:

Excel funkce OR

Pokročilejší použití s KDYŽ

mám více podmínek a ptřebuji rozhodnou bvyzžitím funkce KDYŽ.

=KDYŽ(NEBO(B8;C8=1);150;0) =KDYŽ(NEBO(B14=NEPRAVDA;C14=0);200;0) ... Excel funkce OR

Podmíněné formátování a funkce A

Využijete podmíněné formátování. Více o podmíněném formátování jsem sepsal zde.

Příklad 1

Budete potřebovat zabarvit buňky, pokud se čísla v řádku rovnají 6 nebo 7. Neboli v kalendáři budu zabarvovat víkendové dny.

Excel funkce NEBO OR - podmíněné formátování

Využijete podmíněné formátování a nastavíte:

=NEBO($C8=6;$C8=7) Excel funkce NEBO OR - podmíněné formátování

Ověření dat a funkce NEBO

Potřebuji do buňky kontrolovat zadávání čísla, které musí být buď 6 nebo 7.

Excel funkce NEBO - OR

Řešení

Využít ověření dat, které je podrobněji popsáno zde. V ověření dat vyplníte jen:

=NEBO(B9=B7;B9=B8) Excel funkce OR

Mlčky předpokládám základní znalost smíšeného odkazování. Jen pro připomenutí, kdyby si náhodou někdo nebyl jistý, tak více informací je v samostatném článku smíšené odkazování.

NEBO ve VBA

Zápis funkce do buňky pomocí VBA:

Range("D5").Formula = "=OR(B5,C5)" Range("D6").FormulaLocal = "=NEBO(B6;C6)" Vysledek = WorksheetFunction.Or(True, False) MsgBox (Vysledek) If True Or False Then MsgBox ("ano") End If Excel funkce PRAVDA - VBA Excel

Související články


Microsoft Excel VBA - stahuj logo

Ke stažení

Soubor ke stažení zdarma je v přípravě.


Závěrem

Využíváte nějaký trik s funkcí A, můžete zmínit v komentářích.

Článek byl aktualizován: 27.01.2017 15:37

Odměna

Ušetřil vám tento web čas, peníze? Pomohl vyřešit problém? Jste ochotni poskytnout symbolickou odměnu na další rozvoj? Vybrte si formu odměny, která vám vyhovuje.


Pavel Lasák - autor webu

Pavel Lasák

Microsoft Office (Word, Excel, Google tabulky, PowerPoint) se věnuji od roku 2000 (od 2004 na této doméně) - V roce 2017 jsem od Microsoft získal prestižní ocenění MVP (zatím jsem jediný z ČR v kategorií Excel). Své vědomosti a zkušenosti dávám k dispozici i on-line ve videích pro SEDUO. Ve firmách školím a konzultuji, učím na MUNI. Tento web již tvořím přes 15 let. Zdarma je zde přes 1.000 návodu, tipů a triků, včetně přes 250 různých šablon, sešitů.

   Pavel Lasák LinkedIn Profil    Pavel Lasák Google+ Profil    Pavel Lasák facebook Profil    Pavel Lasák twitter Profil


Komentáře zatím nejsou

Můžete být prvními co zanechají smysluplný komentář.







Sdílejte

Pomohl Vám návod?
Sdílejte na Facebooku, G+
LinkedIn...

Nové články


TOPlist Licence Creative Commons webarchiv rss XML

Stránky o MS Office (Excel) produktu společnosti Microsoft. Neslouží jako technická podpora.
| Email na autora: pavel.lasak@gmail.com | Copyright © : Pavel Lasák 2004 - 2018 | 4415

Tento web zatím neprošel jazykovou korekturou. Beta verze redakčního systému.