Přeskočit navigaci | Přeskočit na novinky
     

Jste zde: Úvodní stránka » excel » funkce-logicke » KDYZ-IF-datum-cas-funkce-Excel
Microsoft Excel logo

KDYŽ (IF) - s datum a čas Excel

Videokurzy Excel

Ve spolupráci se SEDUO jsem vytvořil několik videokurzů:

Jak na podmínky ve funkci KDYŽ ve spojení s datum a čas. Aneb nezapomenout, že datum a čas jsou na pozadí čísla, desetinná čísla.

Úvodem do funkce KDYŽ ve spojení s datum a čas

Pro přehlednost je rozdělen na kapitoly:


Datum a čas - rychlá teorie

Předpokládám znalost základního použití funkce KDYŽ a jak fungují funkce pro datum a čas. Pokud si nejste jistí, můžete si znalosti ověřit:

Rychlá teorie - opakování

Syntaxe KDYŽ

=KDYŽ(Podmínka; [Ano]; [Ne])

Jak funguje datum. První indexovatelný den 1.1.1900 (vím je to složitější, ale beru základní nastavení Excel) což je 1 a každé následující den o jedničku větší. Čas desetinné číslo, nebo-li 0,5 je poledne. Datum s časem příslušné desetinné číslo (1,5 je 1.1.1900).

Pozor u datum (čas), zajímá Excel číslo co je na "pozadí", to co vidíte nemusí být skutečnost. Můžete vidět jen čas a přitom jde i o datum, které díky formátování není zobrazeno. Případně může být díky formátování přehozen měsíc a den! Toto může mít drastické dopady i v emailech pokud máte v emailu z anglicky mluvicí země uveden datum 3.4.2018 (bez údaje o který měsíc se jedná). Nevíte na 100%, zda jde o 3.duben, nebo 4. březen (v Excel je to jednoduché - podíváte se na formát buňky ;).

KDYŽ - ve spojení s DNES

Potřebuji zjistit, zda datum uvedený v buňce je starší než dnes. Protože potřebuji výpočet dynamicky (tj. musí fungovat i další den automaticky), využiji funkci pro zjištění dnešního dne DNES (TODAY v angličtině):

=KDYŽ(B7<DNES();"ANO";"NE") Excel funkce KDYŽ

Tip

V buňce je datum v českém formátu, den.měsíc.rok

KDYŽ - hodnota datum napřímo

Potřebuji zjistit, zda hodnota datum je před, nebo po zadaném datumu, který je zadán:

  • datum je uvedeno v buňce
  • datum se zadá napřímo do vzorce

Datum je uvedeno v buňce

Jednodužší postup, pokud máte datum v bunce, jako v mém případě v bunce C22.

=KDYŽ(B25<$C$22;"ANO";"NE")

Datum se zadá napřímo do vzorce

Pokud chcete zadat vzorec napřímo doporučuji využít funkci DATUMHODN (pokud tento údaj nemáte v buňce na kterou se můžete odkázat).

=KDYŽ(B28<DATUMHODN("25.07.2018");"ANO";"NE")

Pozor, nelze porovnávat jen hodnotu datum zadanou do buňky. Jak víte datum je číslo a ne text, který zápisem do uvozovek máte v buňce.

=KDYŽ(B31<"25.07.2018";"ANO";"NE") Excel funkce KDYŽ

Tip

Výhodou funkce DATUMHODN, je že datum můžete poskládat například využitím funkce CONCATENATE:

=KDYŽ(B28<DATUMHODN(CONCATENATE(25;".";7;".";2018));"ANO";"NE")

Samozřejmě se můžete odkazovat i na příslušné buňky, a hodnoty dne, měsíce roku nemusíte zapisovat do funkce napřímo ;)

KDYŽ - ve spojení s NYNI (NOW)

Potřebuji zjistit zda datum s časem uvedený v bunce je starší než aktuální datum s časem. Protože potřebuji výpočet dynamicky (tj. musí fungovat při každém přepočtu listu), využiji funkci pro zjištění aktuálního dne s časem neboli funkci NYNY (NOW v angličtině):

=KDYŽ(I7<NYNÍ();"ANO";"NE") Excel funkce KDYŽ ve spojení s NYNI

Tip

Využívá se datum i čas. Pokud půjde jen o aktuální čas od NYNI lze odečíst DNES ;)

=NYNÍ()-DNES()

Výsledkem bude pouze aktuální čas:

12:01 potažmo 00.01.1900 12:01 neboli den 0 (nula)

KDYŽ - hodnota čas napřímo

Potřebuji zjistit zda hodnota čas, datum s časem je před, nebo po zadaném času (datum včetně času), který je zadán:

  • čas je uvedeno v buňce
  • čas se zadá napřímo do vzorce

Čas je uvedeno v buňce

Jednodušší postup, pokud máte čas (datum včetně času) v bunce, jako v mém případě v buňce J25.

=KDYŽ(I28<$J$25;"ANO";"NE")

Čas se zadá napřímo do vzorce

Opět jako u datum se musí zadávat využítím funkce ČASHODN (TIMEVALUE v angličtině).

=KDYŽ(I28<ČASHODN("10:00");"ANO";"NE") Excel funkce KDYŽ

Tip

Opět pozor jak je datum, datum s časem uveden. Neboli skutečná hodnota v buňce.

Jak číslo představující datum s časem již nemusím dodávat, ale pro kontrolu ;)

DATUMHODN("25.07.2018")+ČASHODN("10:15")

Jen funkce DATUMHODN a ČASHODN sečtete.

Související články s KDYŽ ve spojení s datum a čas

Další články související se funkci KDYŽ při práci s datum a čas:


Microsoft Excel VBA - stahuj logo

Ke stažení ukázka KDYŽ - prakticky

Soubor pro práci s datum a čas ve spojeni s funkcí KDYŽ a dalšími je v přípravě.


Závěrem

Využíváte nějaký trik s funkci KDYŽ ve spojení s datum a čas? Případně pokud tuto funkci využíváte jinak (lépe), můžete zmínit v komentářích.

Článek byl aktualizován: 25.07.2018 12:34

Odměna

Ušetřil vám tento web čas, peníze? Pomohl vyřešit problém? Jste ochotni poskytnout symbolickou odměnu na další rozvoj? Vybrte si formu odměny, která vám vyhovuje.


Pavel Lasák - autor webu

Pavel Lasák

Microsoft Office (Word, Excel, Google tabulky, PowerPoint) se věnuji od roku 2000 (od 2004 na této doméně) - V roce 2017 jsem od Microsoft získal prestižní ocenění MVP (zatím jsem jediný z ČR v kategorií Excel). Své vědomosti a zkušenosti dávám k dispozici i on-line ve videích pro SEDUO. Ve firmách školím a konzultuji, učím na MUNI. Tento web již tvořím přes 15 let. Zdarma je zde přes 1.000 návodu, tipů a triků, včetně přes 250 různých šablon, sešitů.

   Pavel Lasák LinkedIn Profil    Pavel Lasák Google+ Profil    Pavel Lasák facebook Profil    Pavel Lasák twitter Profil


Komentáře zatím nejsou

Můžete být prvními co zanechají smysluplný komentář.







Sdílejte

Pomohl Vám návod?
Sdílejte na Facebooku, G+
LinkedIn...

Nové články


Reklama


TOPlist Licence Creative Commons webarchiv rss XML

Stránky o MS Office (Excel) produktu společnosti Microsoft. Neslouží jako technická podpora.
| Email na autora: pavel.lasak@gmail.com | Copyright © : Pavel Lasák 2004 - 2019 | 3684

Tento web zatím neprošel jazykovou korekturou. Beta verze redakčního systému.