Přeskočit navigaci | Přeskočit na novinky
     

Jste zde: Úvodní stránka » excel » ostatni » sierpinskeho-trojuhelnik-fraktal

Sierpinského trojúhelník - fraktál

Videokurzy Excel

Ve spolupráci se SEDUO jsem vytvořil několik videokurzů:

aneb trochu hrátek s Microsoft Excelem - ať je vidět že i na "ptákoviny" lze Excel použít.

Úvodem

Sierpinského trojúhelník - fraktal

Sierpinského trojúhelník je fraktál, který vytvoří trojúhelník. Jméno nese tento fraktál po slavném matematikovi Wacław Sierpińský (rodák z Polska), který jej popsal.

Jeho tvorba je jednoduchá. Buňky jsou buď obarvené nebo neobarvené (PRAVDA/NEPRAVDA). První buňka na vrcholu trojúhelníka je obarvená. V další řadě se pro každou buňku kontroluje, zda ve třech buňkách, které jsou nad touto buňkou (vpravo nad, nad, vlevo nad) je pouze jedna z těchto buněk obarvená. Pokud je pouze jedna obarvená, bude testovaná buňka také mít barvu. Pokud ne zůstane bez barvy. Nejlépe pochopitelné je na ukázce.


Ukázka "logických funkcí" aneb jak zjistit co bude o řadu níže.

Sierpinského trojúhelník - fraktál

Jak na to v Excelu

Potřebujete jen zjistit, co se nachází o patro výše. A pokud je součet (suma) buněk rovná jedné zapíše se do buňky jednička. Jinak buňka zůstane prázdná.

Využijeme funkci, která vyřeší 1 do buněk, které jí mají obsahovat.

=KDYŽ(SUMA(D3:F3)=1;1;"")

List doplníme o podmíněné formátování.

Zúžíme sloupce a máme hotovo.

Sierpinského trojúhelník - fraktál

Ke stažení

Soubor Sierpinského trojúhelník - fraktal soubor ve formátu *.xlsx ke stažení zdarma.

Závěrem

Víte o nějaké jiné zajímavé hříčce pro Excel? Můžete se zmínit v komentářích.

Článek byl aktualizován: 01.11.2014 11:50

Odměna

Ušetřil vám tento web čas, peníze? Pomohl vyřešit problém? Jste ochotni poskytnout symbolickou odměnu na další rozvoj? Vybrte si formu odměny, která vám vyhovuje.


Pavel Lasák - autor webu

Pavel Lasák

Microsoft Office (Word, Excel, PowerPoint) se věnuji od roku 2000 (od 2004 ne této doméně) - Roku 2017 jsem od Microsoft získal prestižní ocenění MVP (zatím jsem jediný z ČR v kategorií Excel). Své vědomosti a zkušenosti dávám k dispozici také na on-line videích pro SEDUO. Školím a konzultuji, učím na MUNI. Hlavně tvořím tento web. Je zde k dispozici přes 1.000 návodu, tipů a triků včetně stovek různých šablon, sešitů.

   Pavel Lasák LinkedIn Profil    Pavel Lasák Google+ Profil    Pavel Lasák facebook Profil    Pavel Lasák twitter Profil


Komentáře zatím nejsou

Můžete být prvními co zanechají smysluplný komentář.






Excel


Sdílejte

Pomohl Vám návod?
Sdílejte na Facebooku, G+
LinkedIn...

Nové články


Newsletter

Přihlaste se odběru novinek a získejte:
Ebook zdarma -
10 kroků ke zvládnutí (Word, Excel, PowerPoint)
Šipka Kniha 3D Více o ebooku ...

TOPlist Licence Creative Commons webarchiv rss XML

Stránky o MS Office (Excel) produktu společnosti Microsoft. Neslouží jako technická podpora.
| Email na autora: pavel.lasak@gmail.com | Copyright © : Pavel Lasák 2004 - 2017 | 4301

Tento web zatím neprošel jazykovou korekturou. Beta verze redakčního systému.