Přeskočit navigaci | Přeskočit na novinky
     

Jste zde: Úvodní stránka » excel » ostatni » sierpinskeho-trojuhelnik-fraktal

Sierpinského trojúhelník - fraktál

Videokurzy Excel

Ve spolupráci se SEDUO jsem vytvořil několik videokurzů:

aneb trochu hrátek s Microsoft Excelem - ať je vidět že i na "ptákoviny" lze Excel použít.

Úvodem

Sierpinského trojúhelník - fraktal

Sierpinského trojúhelník je fraktál, který vytvoří trojúhelník. Jméno nese tento fraktál po slavném matematikovi Wacław Sierpińský (rodák z Polska), který jej popsal.

Jeho tvorba je jednoduchá. Buňky jsou buď obarvené nebo neobarvené (PRAVDA/NEPRAVDA). První buňka na vrcholu trojúhelníka je obarvená. V další řadě se pro každou buňku kontroluje, zda ve třech buňkách, které jsou nad touto buňkou (vpravo nad, nad, vlevo nad) je pouze jedna z těchto buněk obarvená. Pokud je pouze jedna obarvená, bude testovaná buňka také mít barvu. Pokud ne zůstane bez barvy. Nejlépe pochopitelné je na ukázce.


Ukázka "logických funkcí" aneb jak zjistit co bude o řadu níže.

Sierpinského trojúhelník - fraktál

Jak na to v Excelu

Potřebujete jen zjistit, co se nachází o patro výše. A pokud je součet (suma) buněk rovná jedné zapíše se do buňky jednička. Jinak buňka zůstane prázdná.

Využijeme funkci, která vyřeší 1 do buněk, které jí mají obsahovat.

=KDYŽ(SUMA(D3:F3)=1;1;"")

List doplníme o podmíněné formátování.

Zúžíme sloupce a máme hotovo.

Sierpinského trojúhelník - fraktál

Ke stažení

Soubor Sierpinského trojúhelník - fraktal soubor ve formátu *.xlsx ke stažení zdarma.

Závěrem

Víte o nějaké jiné zajímavé hříčce pro Excel? Můžete se zmínit v komentářích.

Článek byl aktualizován: 01.11.2014 11:50

Odměna

Ušetřil vám tento web čas, peníze? Pomohl vyřešit problém? Jste ochotni poskytnout symbolickou odměnu na další rozvoj? Vybrte si formu odměny, která vám vyhovuje.


Pavel Lasák

Pavel Lasák - autor webu

Microsoft Office (Word, Excel, PowerPoint) se věnuji od roku 2006. Své vědomosti a zkušenosti dávám k dispozici na různých školeních a konzultacích, ale také na tomto webu. K dispozici na tomto webu je mnoho návodu, tipů a triků včetně desítek různých šablon.

   Pavel Lasák LinkedIn Profil    Pavel Lasák Google+ Profil    Pavel Lasák facebook Profil    Pavel Lasák twitter Profil

Doporučte tento článek přátelům

Pokud vám článek pomohl, případně si myslíte, že může pomoci i někomu dalšímu, budu rád když jej sdílením doporučíte přátelům - děkuji:



Komentáře zatím nejsou

Můžete být prvními co zanechají smysluplný komentář.






Excel


Sdílejte

Pomohl Vám návod?
Sdílejte na Facebooku, G+
LinkedIn...

Nové články

25.03.2017:
ROUNDUP, ROUNDDOWN - zaokrouhlování

07.04.2017:
Řazení Excel - bug - problém

09.04.2017:
Podmínkové funkce Excel - bug - problém


Newsletter

Přihlaste se odběru novinek a získejte:
Ebook zdarma -
10 kroků ke zvládnutí (Word, Excel, PowerPoint)
Šipka Kniha 3D Více o ebooku ...

TOPlist Licence Creative Commons webarchiv rss XML

Stránky o MS Office (Excel) produktu společnosti Microsoft. Neslouží jako technická podpora.
| Email na autora: pavel.lasak@gmail.com | Copyright © : Pavel Lasák 2004 - 2017 | 4002

Tento web zatím neprošel jazykovou korekturou. Beta verze redakčního systému.