Přeskočit navigaci | Přeskočit na novinky
     

Jste zde: Úvodní stránka » excel » matice » matice-prakticke-priklady-excel

Matice - praktické příklady - Excel

Videokurzy Excel

Ve spolupráci se SEDUO jsem vytvořil několik videokurzů:

... praktické příklady na matice ...

Poslední aktualizace: 31.1.2015 - článek je průběžně aktualizován a doplňován.

Seznam příkladu na matice

Microsoft Excel logo

V tomto článku jsou zatím k dispozici tyto prakticky řešené příklady:


Teoretické předpoklady

V tomto článku předpokládám základní znalost maticového počtu a způsob vkládání matice pomocí klávesové zkrátky Ctrl+Shift+Enter.

Pokud si nejste jistí je k dipozici článek: úvod do maticového počtu v Microsoft Excel.

Součet, součin pomocí matic

V následujíci tabulce potřebujeme sečíst A * B, případně vynásobit A * B hodnoty v jednotlivých řádcích.

A    B   
1 2
2 4
3 6
4 8

Klasickou metodou vložit =A1+B1 a rozkopírovat nahradíme maticovým počtem.

Maticově lze provést v označené oblasti pomocí vzorce pro součet:

{=B6:B9+C6:C9)}

a pro součin:

{=B14:B17*C14:C17)}

Ukázkové řešení

Matice součet součin - Excel - řešení

SUMA pro součin v maticovém počtu

Máme tabulku a potřebujeme SUMU, A * B pro všechny sloupce.

A    B   
1 2
2 4
3 6
4 8

Klasicky lze řešit přidáním dalšího sloupce se součinem A * B a pod tento sloupec provést SUMU.

Maticově lze provést v jedné buňce:

{=SUMA(B5:B8*C5:C8)} Matice SUMA / Excel - řešení

Počet hodnot v daném řádku

Z následujíci tabulce potřebujeme ve vybraném řádku sečíst počet požadovaných hodnot.

Matice zdrojová tabulka - Excel - řešení

Maticový vzorc:

{=SUMA((B6:B12=C15)*(C6:J12=C16))}

Ukázkové řešení

Matice počet hodnot ve vybraném řádku - Excel - řešení

Pozice (řádek/sloupec) hodnoty v matici

Otázka: Mám matici, které obsahuje jedinečné prvky. Potřebuji zjistit pozici (řádek/sloupec) zadané hodnoty. Mám například matici jako na obrázku níže a po zadaní 4 potřebuji dostat sloupec 3 a řádek 4.

Poznámka: Předpoklad, čísla v matici jsou unikátní (neopakuji se).

MS Excel 2010 - matice ukázka

Zdrojová data

Máme k dispozici matici. Matice nezačíná v buňce A1, ale v B5. V D13 je hledaná hodnota. Úkol je do D15,D16 doplnit řádek, sloupec na kterém se námi hledaná hodnota nachází. Pozor: První řádek matice je na řádku 5 v našem příkladu v Excelu.

MS Excel 2010 - matice ukázka

Řešení

Do příslušných buněk D15,D16, zapíšeme maticovým zápisem příslušené vzorce:

=SUMA((B5:D8=D13)*(SLOUPEC(B5:D8)-1)) =SUMA((B5:D8=D13)*(ŘÁDEK(B5:D8)-4))

Pozor: Nezapomenout zapsat jako maticový vzorec pomocí klávesové zkratky Ctrl+Shift+Enter.

Výsledek

Pokud postupujete správně obdržíte:

MS Excel 2010 - vysledek matice ukázka

Ke stažení

Soubor řádek sloupec hodnoty v matici soubor ve formátu *.xlsx pro Microsoft Excel - ke stažení zdarma. Pokud si chcete informace ověřit a nechce se vám vytvářet matice samostatně. ;)

Závěrem

Pokud máte v zásobě nějaké zajímavé řešení příkladu na použití matic můžete se zmínit v komentářích. Pokusím se do článku doplnit.

Článek byl aktualizován: 31.01.2015 19:25

Odměna

Ušetřil vám tento web čas, peníze? Pomohl vyřešit problém? Jste ochotni poskytnout symbolickou odměnu na další rozvoj? Vybrte si formu odměny, která vám vyhovuje.


Pavel Lasák

Pavel Lasák - autor webu

Microsoft Office (Word, Excel, PowerPoint) se věnuji od roku 2006. Své vědomosti a zkušenosti dávám k dispozici na různých školeních a konzultacích, ale také na tomto webu. K dispozici na tomto webu je mnoho návodu, tipů a triků včetně desítek různých šablon.

   Pavel Lasák LinkedIn Profil    Pavel Lasák Google+ Profil    Pavel Lasák facebook Profil    Pavel Lasák twitter Profil

Doporučte tento článek přátelům

Pokud vám článek pomohl, případně si myslíte, že může pomoci i někomu dalšímu, budu rád když jej sdílením doporučíte přátelům - děkuji:



Komentáře


Martin Zlámal

Přidáno: 29.09.13 11:15

Hezký nápad! Jen v případě duplicity hledaného výrazu bude SUMA vracet nesmysly. Pokud by mi stačil první nalezený výraz v tabulce prohledávané po řádcích, tak řešením je třeba: {=MIN(KDYŽ(=;1;1E+30)*(ŘÁDEK()-4&","&SLOUPEC()-1))} Číslo řádku a sloupce lze pak získat samostatně třeba pomocí fce CELÁ.ČÁST Jinak to celé se dá řešit i bez matic s využitím funkcí POZVYHLEDAT a INDEX.

Pavel Lasák

Přidáno: 30.09.13 18:17

To Martin Zlámal: Děkuji za doplnění. Jde jen o ukázku jak se dají nestandartně využít matice. Osobně bych také šahl po POZVYHLEDAT a INDEX.







Sdílejte

Pomohl Vám návod?
Sdílejte na Facebooku, G+
LinkedIn...

Nové články

25.03.2017:
ROUNDUP, ROUNDDOWN - zaokrouhlování

07.04.2017:
Řazení Excel - bug - problém

09.04.2017:
Podmínkové funkce Excel - bug - problém


Newsletter

Přihlaste se odběru novinek a získejte:
Ebook zdarma -
10 kroků ke zvládnutí (Word, Excel, PowerPoint)
Šipka Kniha 3D Více o ebooku ...

TOPlist Licence Creative Commons webarchiv rss XML

Stránky o MS Office (Excel) produktu společnosti Microsoft. Neslouží jako technická podpora.
| Email na autora: pavel.lasak@gmail.com | Copyright © : Pavel Lasák 2004 - 2017 | 7515

Tento web zatím neprošel jazykovou korekturou. Beta verze redakčního systému.