Přeskočit navigaci | Přeskočit na novinky

Videokurzy na Seduo: Excel pro začátečníky (přes 13.000 studujících) nebo kompletní kurz Excel (6 hodin - 160 videí).

     

Jste zde: Úvodní stránka » excel » grafy » graf-excel-vyber-zobraz-radu-v-grafu

Graf - výběr datove řady k zobrazení - Excel


Jak automaticky vybrat datovou řadu, která bude zobrazena?

Úvodem

Cílem článku je ukázat jak je možno pomocí zaškrtnutí v zaškrtávacím poli zobrazit potřebnou datovou řadu.

Vhodné při prezentacích kdy například potřebujete zobrazit jen určitou řadu a ostatní zatím nechat skryté. Případně následně automaticky generujete grafy pro určitá oddělení ve fimě a nechcete dávat k dispozici kompletní náhledy.

Ukázky

Excel Graf
Excel Graf

Máte k dispozici seznam výrobku a k němu příslušné hodnoty. Pomocí ovládacích prvků je potřeba vybrat (zvýraznit) požadovanou datovou řadu. Toto se naučíte v tomto článku.

Zdrojová data

Než začnete, budete potřebovat zdrojová data. Například takovouto tabulku:

Zdrojová data: Excel Graf

Ke stažení

Soubor zdrojová data pro graf Excel soubor ve formátu *.xls ke stažení zdarma.

Postup možného řešení

Provedete tyto kroky:

  • Vložení ovládacího prvku
  • Funkce
  • Vložení grafu

Vložení ovládacího prvku

Jelikož předpokládám, že již z předchozí kapitoly máte k dispozici zdrojovou tabulku, můžete pokračovat vložením ovládacích prvků. Můžete si vybrat mezi zaškrtávacím políčkem, nebo pole se seznamem.

Podrobněji jak na ovládací prvky v samostatném článku Ovládací prvky formuláře - v Excelu.

Funkce

Využít pevně nastavených limit pro osu, kdy v případě, že nechceme osu zobrazit pomocí funkce KDYŽ přiřadíme hodnotu mimo osu.

=KDYŽ($C$4=NEPRAVDA;-1;F6)

nebo využít funkci NEDEF

=KDYŽ($E$4=NEPRAVDA;NEDEF();H15)

v případě použití pole se seznamem přidáte další sloupec s vybranou datovou řadou, která bude zobrazena.

=KDYŽ($L$7=1;C10;KDYŽ($L$7=2;D10;E10))

Podrobněji o funkci KDYŽ

Vložení grafu

Pro takto upravenou tabulku stačí vytvořit graf.

A máte HOTOVO.

Jak na grafy v samostatné sekci Jak na grafy v Excel

Excel Graf

Ke stažení

Prezentované ukázky si můžete stáhnout zdarma

Závěrem

Využívate zvýraznení datových řad v grafech?

Článek byl aktualizován: 01.11.2014 11:26

Odměna

Ušetřil vám tento web čas, peníze? Pomohl vyřešit problém? Jste ochotni poskytnout symbolickou odměnu na další rozvoj? Vybrte si formu odměny, která vám vyhovuje.


Pavel Lasák

Pavel Lasák - autor webu

Microsoft Office (Word, Excel, PowerPoint) se věnuji od roku 2006. Své vědomosti a zkušenosti dávám k dispozici na různých školeních a konzultacích, ale také na tomto webu. K dispozici na tomto webu je mnoho návodu, tipů a triků včetně desítek různých šablon.

   Pavel Lasák LinkedIn Profil    Pavel Lasák Google+ Profil    Pavel Lasák facebook Profil    Pavel Lasák twitter Profil

Doporučte tento článek přátelům

Pokud vám článek pomohl, případně si myslíte, že může pomoci i někomu dalšímu, budu rád když jej sdílením doporučíte přátelům - děkuji:



Komentáře


Monika

Přidáno: 23.02.15 17:11

Dobrý den, prosím, nevíte, jak aktualizovat graf (mám spoustu grafů na listu), takže pomocí vba (ne ručně) - mám Excel 2013? Protože i Váše ukázka mi nefunguje správně - Ukázka grafu - zvýrazni datovovou řadu (3), měním výběr v ovládacím prvku, tak se graf neaktualizuje, resp. ta zvýrazněná křivka zůstává stále ta samá... v Excel 2010 mi to fungovalo normálně... Díky moc za případnou odpověď

Pavel Lasák

Přidáno: 20.12.15 10:04

To Monika: Co po stisku klávesy F9 provede se změna? Když změníte v buňce J6 hodnotu z 1 na 2 (3) změní se křivka?






Excel


Sdílejte

Pomohl Vám návod?
Sdílejte na Facebooku, G+
LinkedIn...

Nové články

25.03.2017:
ROUNDUP, ROUNDDOWN - zaokrouhlování

07.04.2017:
Řazení Excel - bug - problém

09.04.2017:
Podmínkové funkce Excel - bug - problém


Newsletter

Přihlaste se odběru novinek a získejte:
Ebook zdarma -
10 kroků ke zvládnutí (Word, Excel, PowerPoint)
Šipka Kniha 3D Více o ebooku ...

TOPlist Licence Creative Commons webarchiv rss XML

Stránky o MS Office (Excel) produktu společnosti Microsoft. Neslouží jako technická podpora.
| Email na autora: pavel.lasak@gmail.com | Copyright © : Pavel Lasák 2004 - 2017 | 5127

Tento web zatím neprošel jazykovou korekturou. Beta verze redakčního systému.