Přeskočit navigaci | Přeskočit na novinky
     

Jste zde: Úvodní stránka » excel » funkce » kombinovani-funkci-vzorcu-excel

Kombinování funkcí (vzorců)

Videokurzy Excel

Ve spolupráci se SEDUO jsem vytvořil několik videokurzů:

Jak kombinovat několika funkcí v Microsoft Excelu. aneb při profesionální práci je člověk nucen funkce kombinovat.

Hledáte-li funkci ministra v kombinaci s náměstkem jste na špatné adrese ;)

Úvodem

Microsoft Excel praxe logo

V tomto článku posupně uvěřejňuji odpovědi na různé dotazy ohledně funkcí. Kdy již nestačí použít jednu, ale je potřeba zkombinovat funkcí několik.

Samostatně funkce určitě dokážete použít. V tomto článku ukázují, jak se jednotlivé funkce dají kombinovat a z výpočtu získat daleko více, než jen při použití jedné funkce.

Pro pochopení předpokládám, že teorií funkcí znáte. Proto je uvedeno jen řešení:

Přehled řešených příkladů v tomto článku:



01 Tvorba rodného čísla z data narození

Vytvoření prvních 6 číslic v rodném čísle. Máme zadán rok, měsíc, den narození a pohlaví

  • C3 den narození 1 - 31
  • C4 měsíc narození 1 - 12
  • C5 rok narození 1901-2012
  • C6 - pohlaví M - můž F - žena (nepíši sex - někdo by odpověděl ANO každý den)
=CONCATENATE(ZPRAVA(C5;2);KDYŽ(C6="F";KDYŽ(DÉLKA(C4)=1;CONCATENATE(0;C4);C4)+50;KDYŽ(DÉLKA(C4)=1;CONCATENATE(0;C4);C4));KDYŽ(DÉLKA(C3)=1;CONCATENATE(0;C3);C3))

K řešení: Rok uveden jako 4 čísla nutno zkrátit na 2, měsíc, pokud je 1 - 9, doplňuje se 0, byby byli dvě čísla, pokud je žena přičte se 50, den opět rozšíření na dvě čísla (pokud je 0-9).

MS Excel 2010 - postup řešení

Poznámka: Jedno z možných řešení.

Ke stažení zdarma

Soubor Kombinace funkcí v jedné buňce soubor ve formátu *.xls ke stažení zdarma.

02 Z rodného čásla zjisti, zda jde o muže nebo ženu

Řešení je jednoduché. Protože víme, že 3 číslo v rozném čísle znamá pohlaví. Pro muže 0, 1, pro ženy 5 nebo 6 (protože u žen se k měsící narození připočítává číslo 50).

Nejprve oddělit třetí znak (textové funkce)

=ČÁST(A8;3;1)

Ze znaku určit zda je o muže nebo ženu (logické funkce)

=KDYŽ(NEBO(B8="0";B8="1");"MUŽ";"ŽENA")

Ukázka řešení

Microsoft Excel z rodneho čísla určit muž/žena

K zadané SPZ přiřazení kraje (města)

Z tabulky ve kterém je uvedeno písmeno a kraj se pomocí excelovské funkce přiřadí SPZ daný kraj (město).

Postup. Nejprve oddělit druhý znak ze SPZ (obdržíte písmeno, která představuje daný kraj, město). Využije se funkce textová.

=ČÁST(A32;2;1)

Ze znaku určit se určí daný kraj. Využít lze oblíbenou vyhledávací funkci SVYHLEDAT.

=SVYHLEDAT(B32;$E$26:$F$39;2)

Ukázka řešení

Microsoft Excel K zadané SPZ přiřazení kraje (města)

Určení zda je rok přestupný.

Je zadán rok, nebo datum a má se určit (pomocí funkce v Microsoft Excelu), zda se jedná o přestupný rok. Je to jednoduché pokud znáte postup kdy je přestupný rok.

Teorie - logika:

  • 1. Rok je dělitelný 4, přejdi ke kroku 2. Jinak přejdi ke kroku 5.
  • 2. Rok je dělitelná 100, přejdi ke kroku 3. Jinak přejdi ke kroku 4.
  • 3. Rok je dělitelný 400, přejdi ke kroku 4. Jinak přejdi ke kroku 5.
  • 4. Rok je přestupný.
  • 5. Rok není přestupný.

Čerpal jsem z http://support.microsoft.com/kb/790125/csodkaz na jiný server ale trochu jsem upravil logiku, Microsoft to má popsané poněkud zmateně.

Možné řešení 1

Vzorec (funkce) pro celé datum

=KDYŽ(NEBO(MOD(ROK(A43);400)=0;A(MOD(ROK(A43);4)=0;MOD(ROK(A43);100) > 0));"Přestupných rok."; "Není přestupných rok.")

Vzorec (funkce) pokud je zadán jen rok

=KDYŽ(NEBO(MOD(A48;400)=0;A(MOD(A48;4)=0;MOD(A48;100) > 0));"Přestupných rok."; "Není přestupných rok.")

Možné řešení 2

Nebo na to jít "hrubou silou". Když daný datum v měsíci existuje jde o přestupný rok.

Vzorec (funkce) pro celé datum

=KDYŽ(MĚSÍC(DATUM(ROK(A43);2;29))=2;"Přestupných rok."; "Není přestupných rok.")

Vzorec (funkce) pokud je zadán jen rok

=KDYŽ(MĚSÍC(DATUM(A48;2;29))=2;"Přestupných rok."; "Není přestupných rok.")

Ukázka řešení v Microsoft Excelu

Je rok přestupný- řešení pro Microsoft Excel.

V přípravě

Další příklady

Závěr

Další příklady v přípravě.

Článek byl aktualizován: 01.11.2014 09:39

Odměna

Ušetřil vám tento web čas, peníze? Pomohl vyřešit problém? Jste ochotni poskytnout symbolickou odměnu na další rozvoj? Vybrte si formu odměny, která vám vyhovuje.


Pavel Lasák - autor webu

Pavel Lasák

Microsoft Office (Word, Excel, PowerPoint) se věnuji od roku 2000 (od 2004 ne této doméně) - Roku 2017 jsem od Microsoft získal prestižní ocenění MVP (zatím jsem jediný z ČR v kategorií Excel). Své vědomosti a zkušenosti dávám k dispozici také na on-line videích pro SEDUO. Školím a konzultuji, učím na MUNI. Hlavně tvořím tento web. Je zde k dispozici přes 1.000 návodu, tipů a triků včetně stovek různých šablon, sešitů.

   Pavel Lasák LinkedIn Profil    Pavel Lasák Google+ Profil    Pavel Lasák facebook Profil    Pavel Lasák twitter Profil


Komentáře


Jana

Přidáno: 14.06.12 14:44

Dobrý den, potřebuji strašně jednoduchou věc, ale nemůžu na to přijít. Potřebuji udělat v jednom součin a zároveň zaokrouhlení na celé Kč. To vše aby fce uměla najednou. Pomůžete mi prosím? Děkuji

Pavel

Přidáno: 14.06.12 21:34

To Jana: Nap59klad takto =ZAOKROUHLIT(A1*A2;2)

sekac79

Přidáno: 10.10.12 19:49

Zdravim, potrebuji poradit, mam cislo X, a chci zjistit, jestli je delitelne cislem A, nebo B nebo C nebo kombinaci techto cisel (napr. X=10A, X=5A+1C atd.) a pokud je tak dobre, pokud ne tak aby to naslo kombinaci s nejmensim zbytkem po deleni a ukazalo zbytek ...

Pavel Lasák

Přidáno: 10.10.12 20:09

To sekac79: Využít funkce matematické http://office.lasakovi.com/excel/funkce/ms-excel-funkce-matematicke/ a logické http://office.lasakovi.com/excel/funkce/ms-excel-funkce-logicke/

sekac79

Přidáno: 10.10.12 21:27

Ja jsem se zasekl u toho vzorce (nebo vzorcu), ktere maji zjistit jestli je cislo delitelne kombinaci cisel, vubec nemam predstavu jak by to melo vypadat ...

Pavel Lasák

Přidáno: 11.10.12 20:49

To Sekac79: zjistit dělení v A1 =MOD(10;5) a pomocí logických funkcí =KDYŽ(A1=0;"Dělitelné beze zbytku";"Nedělitelné bez zbytku") atd.

jarin

Přidáno: 04.12.12 18:38

dobry den zitra rano pisi pisemku z ivt na excel. rodna cisla a tak. pr. kolik mu je dnes a za jak dlouho mi bude 25 a tak mohli byste mi prosim pomoct :-(

Pavel Lasák

Přidáno: 04.12.12 20:24

To jarin: Doporučuji si projít funkce datum a čas: http://office.lasakovi.com/excel/funkce/ms-excel-datum-a-cas-teorie/ http://office.lasakovi.com/excel/funkce/ms-excel-datum-a-cas-prehled/ http://office.lasakovi.com/excel/funkce/ms-excel-datum-a-cas/ tam naleznete odpovědi tyto a podobné otázky.

Bonati

Přidáno: 05.05.15 14:41

Ahoj Pavle. S rodným číslem to je trochu složitější. Od roku 2004 (zákonem č. 53/2004 Sb.) je navíc zavedena možnost v případě, že jsou v nějaký den vyčerpána všechna platná čtyřčíslí, použít alternativní rodné číslo, kde se k číslu měsíce přičte ještě 20 (tedy u žen celkem 70). http://cs.wikipedia.org/wiki/Rodn%C3%A9_%C4%8D%C3%ADslo#Extern.C3.AD_odkazy

Martin

Přidáno: 11.11.16 07:49

Dobrý den, snažím se vytvořit vzorec, který mi spočítá výsledek dle zadaných parametrů. Když hodnota v buňce A rovná se určitému číslu 1 až 20 spočítej do buňky B dle vzorce. Příklad. vyhledej v buňce A hodnotu a přiřaď k němu vzorec součinu Buňka A1=1 spočítej =SOUČIN(B1/1000*0,12), ale pokud Buňka A1=5 spočítej =SOUČIN(B1/1000*0,57), můžete mi poradit??? Děkuji Sekanina Martin






Excel


Sdílejte

Pomohl Vám návod?
Sdílejte na Facebooku, G+
LinkedIn...

Nové články


Newsletter

Přihlaste se odběru novinek a získejte:
Ebook zdarma -
10 kroků ke zvládnutí (Word, Excel, PowerPoint)
Šipka Kniha 3D Více o ebooku ...

TOPlist Licence Creative Commons webarchiv rss XML

Stránky o MS Office (Excel) produktu společnosti Microsoft. Neslouží jako technická podpora.
| Email na autora: pavel.lasak@gmail.com | Copyright © : Pavel Lasák 2004 - 2017 | 18180

Tento web zatím neprošel jazykovou korekturou. Beta verze redakčního systému.