Přeskočit navigaci | Přeskočit na novinky
     

Jste zde: Úvodní stránka » excel » funkce-vyhledavaci » SVYHLEDAT-specialni-znaky-Excel
Microsoft Excel logo

SVYHLEDAT - speciální znaky ? * - v Excel

Videokurzy Excel

Ve spolupráci se SEDUO jsem vytvořil několik videokurzů:

Jak pomocí SVYHLEDAT najít hodnotu s využitím speciálních znaků ? * ~

Úvodem do funkce SVYHLEDAT

Někdy základní použití SVYHLEDAT nepostačí, kódy ve kterých vyhledáváte pouze unikátní část (nepotřebujete celý). Proč vytvářet pomocný sloupec pomocí textových funkcí, kde si vyparsujete co potřebujete. Stačí přímo ve funkci použít speciální znaky (* ? ~) a máte vyřešeno.

Jak praktiky se dozvíte v tomto články. Opět je rozdělen do kapitol, abych ho mohl dále rozšiřovat podle aktuálních potřeb:


Využití ? ve funkci SVYHLEDAT

Excel funkce SVYHLEDAT - data

Zdrojová data

Nejprve potřebujete zdrojová data.

Půjde o demo tabulku, kde budu potřebovat v celkovém kódu hledat podle jedinečného ID (tři čísla, které následují za dvěma číselnými znaky.


=SVYHLEDAT("??"&D7;B16:C22;2;0)

Spojujete textový řetězec otazník s odkazem na buňku, proto otazník ve dvojitých uvozovkách a spojit pomocí znaku & s odkazovanou buňkou do které budete zadávat hledané číslo.

Excel funkce SVYHLEDAT speciální znak

Poznámka:

Lze použít i klasické použití bez speciálního znaku, ten ale musíte mít ve vyhledávací buňce:

=SVYHLEDAT(D12;B16:C22;2;0)

Budete hledat: ??578

Využití * ve funkci SVYHLEDAT

Excel funkce SVYHLEDAT - data

Zdrojová data

Nejprve potřebujete zdrojová data.

Půjde o demo tabulku, kde budu potřebovat v celkovém kódu hledat podle příjmení. Jen ve sloupci máte kromě příjmení celé jméno (už příjmení je jedinečná hodnota). Získávat příjmení pomocí textových funkcí je sice možné, ale pracné. Stačí doplnit funkci SVYHLEDAT o hvězdičku a máte vyřešeno:


=SVYHLEDAT(D7&"*";B16:C22;2;0)

Samozřejmě stejně jako v přechozím případě spojujete textový řetězec hvězdičku s odkazem na buňku, proto ve dvojitých uvozovkách a spojit pomocí znaku &.

Excel funkce SVYHLEDAT speciální znak

Poznámka:

Lze použít i klasické použití bez speciálního znaku, ten ale musíte mít ve vyhledávací buňce:

=SVYHLEDAT(D12;B16:C22;2;0)

Budete hledat: Bond*

Související články s funkci SVYHLEDAT

Další články související s funkcemi datum a čas:


Microsoft Excel VBA - stahuj logo

Ke stažení

Soubor Jak na speciální znak otazník v SVYHLEDAT Excel soubor ve formátu *.xlsm ke stažení zdarma.

Soubor Jak na speciální znak hvězdička v SVYHLEDAT Excel soubor ve formátu *.xlsm ke stažení zdarma.


Závěrem

Využíváte nějaký trik s funkcí DEN, můžete zmínit v komentářích.

Článek byl aktualizován: 01.09.2017 15:23

Odměna

Ušetřil vám tento web čas, peníze? Pomohl vyřešit problém? Jste ochotni poskytnout symbolickou odměnu na další rozvoj? Vybrte si formu odměny, která vám vyhovuje.


Pavel Lasák - autor webu

Pavel Lasák

Microsoft Office (Word, Excel, PowerPoint) se věnuji od roku 2000 (od 2004 ne této doméně) - Roku 2017 jsem od Microsoft získal prestižní ocenění MVP (zatím jsem jediný z ČR v kategorií Excel). Své vědomosti a zkušenosti dávám k dispozici také na on-line videích pro SEDUO. Školím a konzultuji, učím na MUNI. Hlavně tvořím tento web. Je zde k dispozici přes 1.000 návodu, tipů a triků včetně stovek různých šablon, sešitů.

   Pavel Lasák LinkedIn Profil    Pavel Lasák Google+ Profil    Pavel Lasák facebook Profil    Pavel Lasák twitter Profil


Komentáře zatím nejsou

Můžete být prvními co zanechají smysluplný komentář.







Sdílejte

Pomohl Vám návod?
Sdílejte na Facebooku, G+
LinkedIn...

Nové články


Newsletter

Přihlaste se odběru novinek a získejte:
Ebook zdarma -
10 kroků ke zvládnutí (Word, Excel, PowerPoint)
Šipka Kniha 3D Více o ebooku ...

TOPlist Licence Creative Commons webarchiv rss XML

Stránky o MS Office (Excel) produktu společnosti Microsoft. Neslouží jako technická podpora.
| Email na autora: pavel.lasak@gmail.com | Copyright © : Pavel Lasák 2004 - 2017 | 910

Tento web zatím neprošel jazykovou korekturou. Beta verze redakčního systému.