Přeskočit navigaci | Přeskočit na novinky
     

Jste zde: Úvodní stránka » excel » funkce-vyhledavaci » SVYHLEDAT-dve-stejne-hodnoty-excel
Microsoft Excel logo

SVYHLEDAT - dvě stejné hodnoty - Excel

Videokurzy Excel

Ve spolupráci se SEDUO jsem vytvořil několik videokurzů:

Jak získat odpovídající hodnoty pomocí funkce SVYHLEDAT i v případě více stejných hodnot v argumentu hledat.

Úvodem

Klasické použití funkce SVYHLEDAT je předpokládám jasné, ale co když potřebuji něco pokročilejšího? Například kdy v argumentu hledat jsou dvě a více stejných hodnot.


Stejné číselné hodnoty

Vyhledávám ve sloupci, kde se může nacházet více stejných číselných hodnot (max. 9). Například potřebuji seřadit prodeje od největší hodnoty a k nim dodat příslušné parametry z dalších sloupců.

Ukázka

SVYHLEDAT Excel - stejné hodnoty ukázka

Postup

  • Vypočtu pozici, kolikrát se opakuje
  • Vytvořím složené číslo - budu moci seřadit od největšího jak potřebuji
  • Zopakuji "návratové" hodnoty - které budu vracet, abych mohl použít funkci SVYHLEDAT
  • Vytvořím řadu - od 1 do n
  • Setřídím čísla od největšího
  • Využiji SVYHLEDAT
=COUNTIF($B$9:B9;B9) =CONCATENATE(B9&E9)+0 =C9 =LARGE($F$9:$F$14;I9) =SVYHLEDAT(J9;$F$9:$G$14;2;0)

Stejné textové hodnoty

Mám několik stejných hodnoty (například jméno Iva) a potřebuji přiřadit příslušné hodnoty pomocí funkce SVYHLEDAT.

Ukázka

SVYHLEDAT Excel - stejné hodnoty ukázka

Postup

  • Vypočtu pozici, kolikrát se Iva opakuje
  • Vytvořím složené jméno - budu moci vypsat
  • Zopakuji "návratové" hodnoty - které budu vracet, abych mohl použít funkci SVYHLEDAT
  • Vytvořím řadu - od 1 do n
  • Sestavím hodnotu Iva + číslo
  • Využiji SVYHLEDAT
=COUNTIF($B$9:B9;B9) =CONCATENATE(B9&E9) =C9 =CONCATENATE("iva";I9) =SVYHLEDAT(J9;$F$9:$G$14;2;0)
Microsoft Excel VBA - stahuj logo

Ke stažení

Soubor v přípravě.


Článek byl aktualizován: 18.12.2016 18:05

Odměna

Ušetřil vám tento web čas, peníze? Pomohl vyřešit problém? Jste ochotni poskytnout symbolickou odměnu na další rozvoj? Vybrte si formu odměny, která vám vyhovuje.


Pavel Lasák - autor webu

Pavel Lasák

Microsoft Office (Word, Excel, PowerPoint) se věnuji od roku 2000 (od 2004 ne této doméně) - Roku 2017 jsem od Microsoft získal prestižní ocenění MVP (zatím jsem jediný z ČR v kategorií Excel). Své vědomosti a zkušenosti dávám k dispozici také na on-line videích pro SEDUO. Školím a konzultuji, učím na MUNI. Hlavně tvořím tento web. Je zde k dispozici přes 1.000 návodu, tipů a triků včetně stovek různých šablon, sešitů.

   Pavel Lasák LinkedIn Profil    Pavel Lasák Google+ Profil    Pavel Lasák facebook Profil    Pavel Lasák twitter Profil


Komentáře zatím nejsou

Můžete být prvními co zanechají smysluplný komentář.







Sdílejte

Pomohl Vám návod?
Sdílejte na Facebooku, G+
LinkedIn...

Nové články


Newsletter

Přihlaste se odběru novinek a získejte:
Ebook zdarma -
10 kroků ke zvládnutí (Word, Excel, PowerPoint)
Šipka Kniha 3D Více o ebooku ...

TOPlist Licence Creative Commons webarchiv rss XML

Stránky o MS Office (Excel) produktu společnosti Microsoft. Neslouží jako technická podpora.
| Email na autora: pavel.lasak@gmail.com | Copyright © : Pavel Lasák 2004 - 2017 | 4577

Tento web zatím neprošel jazykovou korekturou. Beta verze redakčního systému.