Přeskočit navigaci | Přeskočit na novinky
     

Jste zde: Úvodní stránka » excel » funkce-vyhledavaci » SLOUPEC-COLUMN-cislo-sloupce-Excel
Microsoft Excel logo

SLOUPEC (COLUMN) - číslo sloupce - Excel

Videokurzy Excel

Ve spolupráci se SEDUO jsem vytvořil několik videokurzů:

Jak zjistit číslo sloupce ve zvolené buňce (zvoleném odkazu).

Úvodem do funkce SLOUPEC

Vrátí číslo sloupce daného odkazu (buňky). v Excel, aneb praktické využití funkce SLOUPEC (v angličtině COLUMN), jednak její použití v listu, tipy, triky až po využití funkce ve VBA.

Jak na funkci SLOUPEC prakticky od A do Z ukazuji v tomto článku, pro přehlednost je rozdělen na kapitoly:


Teorie použití SLOUPEC

Funkce SLOUPEC (v angličtině COLUMN) vrátí číslo sloupce daného odkazu (buňky). Odkaz může být i jako pojmenovaná (definovaná) oblast.

Syntaxe česky:

=SLOUPEC(odkaz)

Syntaxe anglicky:

=COLUMN(odkaz)

Popis argumentů:

  • odkaz - je buňka nebo oblast, jejíž číslo sloupce chcete zjistit. (nepovinný) není-li uveden bere se v potaz aktuální buňka.

Poznámka:

  • Uvedete-li oblast, vrátí jen číslo prvního sloupce.
Excel funkce SLOUPEC - argumenty

Základní použití funkce SLOUPEC

Potřebuji zjistit sloupec.

=SLOUPEC() =SLOUPEC(B6) =SLOUPEC(MojeBunka) =SLOUPEC(8:8) =SLOUPEC(test) Excel funkce SLOUPEC

Kombinace SLOUPEC + ODKAZ

Zkombinovat s funkci ODKAZ. Případně jak dynamicky dopočítávat řádky.

=ODKAZ(ŘÁDEK(B4);SLOUPEC(B4);4) ---------------- =SLOUPEC()-SLOUPEC($B$7)+1 Excel funkce SLOUPEC

SLOUPEC a SVYHLEDAT

Hrátky s SVYHLEDAT, když potřebuji dopočítávat sloupce. Jak automaticky dopočítávat sloupec je uveden v předchozím příkladě, teď to jen použijeme prakticky ve funkci.

=SVYHLEDAT($B$13;$B$5:$F$10;SLOUPEC()-1;NEPRAVDA) nebo elegantněji =SVYHLEDAT($B$15;$B$5:$F$10;SLOUPEC(C15)-SLOUPEC($B$15)+1;NEPRAVDA) Excel funkce SLOUPEC

Použití s funkce SLOUPEC s využitím VBA

Zápis funkce do buňky pomocí VBA:

Range("B4").Formula = "=COLUMN()" Range("B5").FormulaLocal = "=SLOUPEC()" Range("B6").FormulaLocal = "=SLOUPEC(B6)" Excel funkce SLOUPEC - VBA Excel

Související články s funkci SLOUPEC

Další články související se statistickými funkcemi:


Microsoft Excel VBA - stahuj logo

Ke stažení

Soubor v přípravě.


Závěrem

Využíváte nějaký trik s funkcí SLOUPEC, můžete zmínit v komentářích.

Článek byl aktualizován: 20.01.2017 16:21

Odměna

Ušetřil vám tento web čas, peníze? Pomohl vyřešit problém? Jste ochotni poskytnout symbolickou odměnu na další rozvoj? Vybrte si formu odměny, která vám vyhovuje.


Pavel Lasák - autor webu

Pavel Lasák

Microsoft Office (Word, Excel, Google tabulky, PowerPoint) se věnuji od roku 2000 (od 2004 na této doméně) - V roce 2017 jsem od Microsoft získal prestižní ocenění MVP (zatím jsem jediný z ČR v kategorií Excel). Své vědomosti a zkušenosti dávám k dispozici i on-line ve videích pro SEDUO. Ve firmách školím a konzultuji, učím na MUNI. Tento web již tvořím přes 15 let. Zdarma je zde přes 1.000 návodu, tipů a triků, včetně přes 250 různých šablon, sešitů.

   Pavel Lasák LinkedIn Profil    Pavel Lasák Google+ Profil    Pavel Lasák facebook Profil    Pavel Lasák twitter Profil


Komentáře zatím nejsou

Můžete být prvními co zanechají smysluplný komentář.







Sdílejte

Pomohl Vám návod?
Sdílejte na Facebooku, G+
LinkedIn...

Nové články


TOPlist Licence Creative Commons webarchiv rss XML

Stránky o MS Office (Excel) produktu společnosti Microsoft. Neslouží jako technická podpora.
| Email na autora: pavel.lasak@gmail.com | Copyright © : Pavel Lasák 2004 - 2018 | 1565

Tento web zatím neprošel jazykovou korekturou. Beta verze redakčního systému.