Přeskočit navigaci | Přeskočit na novinky
     

Jste zde: Úvodní stránka » excel » funkce-matematicke » SUMA-SUM-soucet-cisel-Excel
Microsoft Excel logo

SUMA (SUM) - součet čísel - Excel

Videokurzy Excel

Ve spolupráci se SEDUO jsem vytvořil několik videokurzů:

Jak sečíst čísla ve zvolené obasti.

Úvodem do funkce SUMA

Jak na součet buněk ve zvolené obasti v Excel, aneb praktické využití funkce SUMA (v angličtině SUM), jednak její použití v listu, grafické znázornění až po využití funkce ve VBA.

Jak na funkci SUMA prakticky od A do Z ukazuji v tomto článku, pro přehlednost je rozdělen na kapitoly:


Teorie použití SUMA

Funkce SUMA (v angličtině SUM) vrátí součet všech čísel ve zvolné oblasti (ve zvolených oblaastech, kterých může být až 255).

Syntaxe česky:

SUMA(číslo1; [číslo2;...])

Syntaxe anglicky:

SUM(číslo1; [číslo2;...])

Popis argumentů:

  • číslo1 ... - je 1 až 255 argumentů (oblastí), které chcete sečíst.

Poznámka:

  • Ve starších verzích Excel bylo argumentu max 30).
  • Chcete-li sčítat jen čísla, které splňují nějakou podmínku doporučuji použít funkce SUMIF , SUMIFS
Excel funkce SUMA - argumenty

Základní použití funkce SUMA

Prodávám fiktivní výrobky a potřebuji zjistit jaká je celková cena.

=SUMA(C5:C11)

Podobně mohu sčítat mzdy, odměny, funkce SUMA je jednou z nejznámnějších a nejčastěji používaných funkcí.

Excel funkce SUMA

Zadání SUMA

Protože se jedná o nejčastěji používanou funkci. Jak jí do buňky zadat?

Aktivní buňka je v buňce do které potřebujeme zadat výpočet. Na kartě Domů ve skupině Úpravy klik ikona SUMA. Maximálně ještě změníme oblast (i když v dobře navržených tabulkách Excel označí správně ;).

Excel funkce SUMA

Jsou i jiné způsoby, ale o tom v samostatném článku.

SUMA dle hodnot

Jak podle různých typu dat, které máte k dispozici, datum, čas, logické funkce,

Excel funkce SUMA - varianty

SUMA chyby

Jak se chová funkce SUMA, když sčítá chybové hodnoty, logické hodnoty, datum a čas? Nebo-li můžemme mít jiný výsledek než původně očekávate.

Excel funkce SUMA - graficky

SUMA maticově

Sumární výpočty mohu nahradit maticovým výpočtem. Podrobněji v samostatném článku o maticových funkcích.

{=SUMA(C27:C30+D27:D30)}

Pro potvrzení samozdřejmě nutno použít Ctrl + Shift + Enter .

Excel funkce SUMA - graficky

SUMA podmínky

Pro práci s podmínkama je míst funkce SUMA vhodnější použít SUMIF a SUMIFS. Ale jsou i možností jak to provést s funkci SUMA.

Podrobnější popis je v přípravě.

Použití s funkce SUMA s využitím VBA

Jak využít funkci SUMA ve VBA:

Dim Vysledek As String Vysledek = WorksheetFunction.Sum(2,4,6) MsgBox (Vysledek)

Zápis funkce do buňky pomocí VBA:

Range("C8").Formula = "=SUM(C5:C7)" Range("C8").FormulaLocal = "=SUMA(C5:C7)" Excel funkce SUMA - VBA Excel

Související články s funkci SUMA

Další články související se statistickými funkcemi:


Microsoft Excel VBA - stahuj logo

Ke stažení

Soubor v přípravě.


Závěrem

Využíváte nějaký trik s funkcí SUMA, můžete zmínit v komentářích.

Článek byl aktualizován: 16.01.2017 14:20

Odměna

Ušetřil vám tento web čas, peníze? Pomohl vyřešit problém? Jste ochotni poskytnout symbolickou odměnu na další rozvoj? Vybrte si formu odměny, která vám vyhovuje.


Pavel Lasák - autor webu

Pavel Lasák

Microsoft Office (Word, Excel, PowerPoint) se věnuji od roku 2000 (od 2004 ne této doméně) - Roku 2017 jsem od Microsoft získal prestižní ocenění MVP (zatím jsem jediný z ČR v kategorií Excel). Své vědomosti a zkušenosti dávám k dispozici také na on-line videích pro SEDUO. Školím a konzultuji, učím na MUNI. Hlavně tvořím tento web. Je zde k dispozici přes 1.000 návodu, tipů a triků včetně stovek různých šablon, sešitů.

   Pavel Lasák LinkedIn Profil    Pavel Lasák Google+ Profil    Pavel Lasák facebook Profil    Pavel Lasák twitter Profil


Komentáře zatím nejsou

Můžete být prvními co zanechají smysluplný komentář.






Excel


Sdílejte

Pomohl Vám návod?
Sdílejte na Facebooku, G+
LinkedIn...

Nové články


Newsletter

Přihlaste se odběru novinek a získejte:
Ebook zdarma -
10 kroků ke zvládnutí (Word, Excel, PowerPoint)
Šipka Kniha 3D Více o ebooku ...

TOPlist Licence Creative Commons webarchiv rss XML

Stránky o MS Office (Excel) produktu společnosti Microsoft. Neslouží jako technická podpora.
| Email na autora: pavel.lasak@gmail.com | Copyright © : Pavel Lasák 2004 - 2017 | 1163

Tento web zatím neprošel jazykovou korekturou. Beta verze redakčního systému.